aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-04-11 15:08:33 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 15:49:33 +0200
commit649556ea092ffb08277b687c791a041cc291ca1e (patch)
tree37f20b74f7d1fc8e74f74f009fc8242a582ccccd /gnu/packages/mpi.scm
parentac2d36559fac296ba5b1c8c3a030dd1e8e0e3fd8 (diff)
downloadguix-649556ea092ffb08277b687c791a041cc291ca1e.tar
guix-649556ea092ffb08277b687c791a041cc291ca1e.tar.gz
gnu: hwloc: Remove trailing #t.
* gnu/packages/mpi.scm (hwloc-1)[arguments]: Remove trailing #t. (hwloc-2)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 32c26e13c0..389fdaa5c4 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -96,8 +96,7 @@
;; machines: <https://github.com/open-mpi/hwloc/issues/213>.
(substitute* "tests/linux-libnuma.c"
(("numa_available\\(\\)")
- "-1"))
- #t))
+ "-1"))))
(add-after 'install 'refine-libnuma
;; Give -L arguments for libraries to avoid propagation
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -114,8 +113,7 @@
;; "lib" output doesn't refer to "out".
(substitute* (string-append lib "/lib/pkgconfig/hwloc.pc")
(("^.*prefix=.*$")
- ""))
- #t)))
+ "")))))
(add-after 'install 'move-man3-pages
(lambda* (#:key outputs #:allow-other-keys)
;; Move section 3 man pages to the "doc" output.
@@ -123,8 +121,8 @@
(doc (assoc-ref outputs "doc")))
(copy-recursively (string-append out "/share/man/man3")
(string-append doc "/share/man/man3"))
- (delete-file-recursively (string-append out "/share/man/man3"))
- #t))))))
+ (delete-file-recursively
+ (string-append out "/share/man/man3"))))))))
(home-page "https://www.open-mpi.org/projects/hwloc/")
(synopsis "Abstraction of hardware architectures")
(description
@@ -168,16 +166,14 @@ bind processes, and much more.")
;; some machines: <https://github.com/open-mpi/hwloc/issues/213>.
(substitute* "tests/hwloc/linux-libnuma.c"
(("numa_available\\(\\)")
- "-1"))
- #t))
+ "-1"))))
(add-before 'check 'skip-test-that-fails-on-qemu
(lambda _
;; Skip test that fails on emulated hardware due to QEMU bug:
;; <https://bugs.gnu.org/40342>.
(substitute* "tests/hwloc/hwloc_get_last_cpu_location.c"
(("hwloc_topology_init" all)
- (string-append "exit (77);\n" all)))
- #t))))))))
+ (string-append "exit (77);\n" all)))))))))))
(define-deprecated hwloc-2.0 hwloc-2)