aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-25 22:47:39 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-26 00:05:39 +0100
commit305eefc0627eb1d047e6fc4320d7e56897719ab8 (patch)
treeb37b13bbcad0317dec5da1317023ae433a58ef1e /gnu/packages/mpi.scm
parentd6d5a67e759075cddd0c0075740ea5628fc8c0d1 (diff)
downloadguix-305eefc0627eb1d047e6fc4320d7e56897719ab8.tar
guix-305eefc0627eb1d047e6fc4320d7e56897719ab8.tar.gz
gnu: hwloc: Add "doc" output.
* gnu/packages/mpi.scm (hwloc-1)[outputs]: Add "doc". [arguments]: Add 'move-man3-pages' phase.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 9035147441..2b73794409 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -69,6 +69,7 @@
(build-system gnu-build-system)
(outputs '("out" ;'lstopo' & co., depends on Cairo, libx11, etc.
"lib" ;small closure
+ "doc" ;400+ section 3 man pages
"debug"))
(inputs
`(("libx11" ,libx11)
@@ -114,6 +115,15 @@
(substitute* (string-append lib "/lib/pkgconfig/hwloc.pc")
(("^.*prefix=.*$")
""))
+ #t)))
+ (add-after 'install 'move-man3-pages
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Move section 3 man pages to the "doc" output.
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (copy-recursively (string-append out "/share/man/man3")
+ (string-append doc "/share/man/man3"))
+ (delete-file-recursively (string-append out "/share/man/man3"))
#t))))))
(home-page "https://www.open-mpi.org/projects/hwloc/")
(synopsis "Abstraction of hardware architectures")