aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorPhilippe SWARTVAGHER <phil.swart@gmx.fr>2023-04-03 11:46:19 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-07 17:38:42 +0200
commit09896b2913e3f383259dab090cab4a537ee97b8c (patch)
tree560cde49aa86e219b0d87ef94ffe1bb18aa5999f /gnu/packages/mpi.scm
parent73ade0bbe58f6d9189050d7929353c90340aee07 (diff)
downloadguix-09896b2913e3f383259dab090cab4a537ee97b8c.tar
guix-09896b2913e3f383259dab090cab4a537ee97b8c.tar.gz
gnu: hwloc: Update to 2.9.1.
* gnu/packages/mpi.scm (hwloc-2): Update to 2.9.1. Patch to skip tests requiring /sys on non-x86 systems should not be necessary anymore, as https://github.com/open-mpi/hwloc/pull/570 has been merged in this new version. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index baef62616f..6faa47c669 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -141,7 +141,7 @@ bind processes, and much more.")
(define-public hwloc-2
(package
(inherit hwloc-1)
- (version "2.9.0")
+ (version "2.9.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -149,7 +149,7 @@ bind processes, and much more.")
"/hwloc-" version ".tar.bz2"))
(sha256
(base32
- "11v8hnl6fdsdbm3wnz5gg88f2ghixjyl7jlfmywj293ab5iyjw10"))))
+ "17jr14a5ns5rpwvy28fy7xqagbvfprsz7wrsjgh5gx7y40d97i3w"))))
;; libnuma is no longer needed.
(inputs (modify-inputs (package-inputs hwloc-1)
@@ -168,16 +168,7 @@ bind processes, and much more.")
(add-before 'check 'skip-tests-that-require-/sys
(lambda _
;; 'test-gather-topology.sh' requires /sys as of 2.9.0; skip it.
- (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")
-
- ;; 'hwloc_backends' also requires /sys on non-x86 systems, for
- ;; which hwloc lacks a topology backend not reliant on the
- ;; operating system; skip it also on these machines.
- (substitute* "tests/hwloc/hwloc_backends.c"
- ,@(if (not (target-x86?))
- '((("putenv\\(\\(char \\*\\) \"HWLOC_L" all)
- (string-append "exit (77);\n" all)))
- '()))))
+ (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")))
(add-before 'check 'skip-test-that-fails-on-qemu
(lambda _
;; Skip test that fails on emulated hardware due to QEMU bug: