aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mingw.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-06-18 13:26:17 +0200
committerChristopher Baines <mail@cbaines.net>2024-07-15 22:34:25 +0100
commitbf6ab0e0f5066d999e027a7eb8ecf05db71123ce (patch)
tree34b8f1fec201745ef89b13dc7b2c3b7fd8110400 /gnu/packages/mingw.scm
parent21bf76c5639952ca6ee8de171739e9521a74f924 (diff)
downloadguix-bf6ab0e0f5066d999e027a7eb8ecf05db71123ce.tar
guix-bf6ab0e0f5066d999e027a7eb8ecf05db71123ce.tar.gz
gnu: mingw-w64-tools: Update to 12.0.0.
* gnu/packages/mingw.scm (mingw-w64-tools): Update to 12.0.0. [arguments]: Remove genlib phases. Change-Id: Ia9060ddb1795ca2941a13435485841dbee0c1200 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/mingw.scm')
-rw-r--r--gnu/packages/mingw.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index c0a258091c..ea579d4043 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -151,7 +151,7 @@ several new APIs such as DirectX and DDK, and 64-bit support.")
(define-public mingw-w64-tools
(package
(name "mingw-w64-tools")
- (version "11.0.1")
+ (version "12.0.0")
(source
(origin
(method url-fetch)
@@ -159,7 +159,7 @@ several new APIs such as DirectX and DDK, and 64-bit support.")
"mirror://sourceforge/mingw-w64/mingw-w64/"
"mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
(sha256
- (base32 "047f4m37kxf7g8qj23qplrzfd9cirfkkv8d175sfv2zfd7hbqriz"))))
+ (base32 "0bzdprdrb8jy5dhkl2j2yhnr2nsiv6wk2wzxrzaqsvjbmj58jhfc"))))
(build-system gnu-build-system)
(arguments
(list
@@ -179,10 +179,6 @@ several new APIs such as DirectX and DDK, and 64-bit support.")
(modify-phases %standard-phases
(replace 'unpack
(lambda _
- (chdir "../genlib"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
(chdir "../genpeimg"))))
(append-map
(lambda (target)