aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-10 14:37:53 -0400
committerLeo Famulari <leo@famulari.name>2017-07-10 14:37:53 -0400
commitc8eb2b8c60d954b4522555a5c75b7bb4be5a1a4d (patch)
tree3a2e569e333ccd9265237868d3f46b2d1e04e3a9 /gnu/packages/messaging.scm
parentad22c7185395a52bd90ea5890a2ac79f44d00352 (diff)
parent61adfb00b11cc16a70e60f19fd8e0a838a3ef608 (diff)
downloadguix-c8eb2b8c60d954b4522555a5c75b7bb4be5a1a4d.tar
guix-c8eb2b8c60d954b4522555a5c75b7bb4be5a1a4d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm59
1 files changed, 55 insertions, 4 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 425a7c4c23..827e9edee9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Theodoros Foradis <theodoros.for@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages libcanberra)
@@ -74,6 +76,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages admin)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages qt)
@@ -484,17 +487,15 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
(define-public gajim
(package
(name "gajim")
- (version "0.16.7")
+ (version "0.16.8")
(source (origin
(method url-fetch)
(uri (string-append "https://gajim.org/downloads/"
(version-major+minor version)
"/gajim-" version ".tar.bz2"))
- (patches
- (search-patches "gajim-CVE-2016-10376.patch"))
(sha256
(base32
- "13sxz0hpvyj2yvcbsfqq9yn0hp1d1zsxsj40r0v16jlibha5da9n"))))
+ "0ckakdjg30fsyjsgyy2573x9nmjivdg76y049l86wns5axw8im26"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1394,4 +1395,54 @@ RFC standards as well as non-standard but popular features. It can be used for
building the IRC clients and bots.")
(license license:lgpl3+)))
+(define-public toxic
+ (package
+ (name "toxic")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/JFreegman/toxic/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0166lqb47f4kj34mhi57aqmnk9mh4hsicmbdsj6ag54sy1zicy20"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'enable-python-scripting
+ (lambda _
+ (setenv "ENABLE_PYTHON" "1")
+ #t)))))
+ (inputs
+ `(("c-toxcore" ,c-toxcore)
+ ("curl" ,curl)
+ ("freealut" ,freealut)
+ ("gdk-pixbuf" ,gdk-pixbuf) ; for libnotify.pc
+ ("libconfig" ,libconfig)
+ ("libnotify" ,libnotify)
+ ("libpng" ,libpng)
+ ("libvpx" ,libvpx)
+ ("libx11" ,libx11)
+ ("ncurses" ,ncurses)
+ ("openal" ,openal)
+ ("python" ,python)
+ ("qrencode" ,qrencode)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/JFreegman/toxic")
+ (synopsis "Tox chat client using ncurses")
+ (description "Toxic is a console-based instant messaging client, using
+c-toxcore and ncurses. It provides audio calls, sound and desktop
+notifications, and Python scripting support.")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here