aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-02-14 17:30:07 -0500
committerLeo Famulari <leo@famulari.name>2023-02-17 14:49:12 -0500
commit7eb3eec4dacc414a6680a97bc6ef38c1f76b947e (patch)
treef004e7c7839d6cacb062e7aef8e1a95220b9aa49 /gnu/packages/messaging.scm
parentb9ecefd1dee2f5947f24db9701b06e05f7e1ae37 (diff)
downloadguix-7eb3eec4dacc414a6680a97bc6ef38c1f76b947e.tar
guix-7eb3eec4dacc414a6680a97bc6ef38c1f76b947e.tar.gz
gnu: psi: Replace with psi-plus.
This is required for <https://issues.guix.gnu.org/53289>. * gnu/packages/messaging.scm (psi): Deprecate in favor of psi-plus.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm59
1 files changed, 3 insertions, 56 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3027d56907..b6e7bc7cf1 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -193,62 +193,6 @@ by @acronym{OMEMO, OMEMO Multi-End Message and Object Encryption}, during
XMPP-based sessions.")
(license license:lgpl3+)))
-(define-public psi
- (package
- (name "psi")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "mirror://sourceforge/psi/Psi/"
- version "/psi-" version ".tar.xz"))
- (modules '((guix build utils)))
- (snippet
- `(begin
- (delete-file-recursively "3rdparty")))
- (sha256
- (base32 "1dxmm1d1zr0pfs51lba732ipm6hm2357jlfb934lvarzsh7karri"))))
- (build-system qt-build-system)
- (arguments
- `(#:tests? #f ; No target
- #:configure-flags
- (list
- "-DUSE_ENCHANT=ON"
- "-DUSE_CCACHE=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-cmake
- (lambda _
- (substitute* "cmake/modules/FindHunspell.cmake"
- (("hunspell-1.6")
- "hunspell-1.7"))
- #t)))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("ruby" ,ruby)))
- (inputs
- `(("aspell" ,aspell)
- ("enchant" ,enchant-1.6)
- ("hunspell" ,hunspell)
- ("libidn" ,libidn)
- ("qca" ,qca)
- ("qtbase" ,qtbase-5)
- ("qtmultimedia-5" ,qtmultimedia-5)
- ("qtsvg-5" ,qtsvg-5)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("x11" ,libx11)
- ("xext" ,libxext)
- ("xcb" ,libxcb)
- ("zlib" ,zlib)))
- (synopsis "Qt-based XMPP Client")
- (description "Psi is a capable XMPP client aimed at experienced users.
-Its design goals are simplicity and stability.")
- (home-page "https://psi-im.org")
- (license license:gpl2+)))
-
(define-public libgnt
(package
(name "libgnt")
@@ -3142,6 +3086,9 @@ social and chat platform.")
designed for experienced users.")
(license license:gpl2+)))
+(define-public psi
+ (deprecated-package "psi" psi-plus))
+
(define-public python-zulip
(package
(name "python-zulip")