aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-06-22 19:54:27 +0900
committerLudovic Courtès <ludo@gnu.org>2023-10-12 18:53:07 +0200
commit2812eb2e1b7ec3409cf823c95da1b676259d8698 (patch)
treeb3252caa4327af6ad2d20420b87561efa46e8670 /gnu/packages/messaging.scm
parenta798477db811d428bfcf91dacb12687dae0d141c (diff)
downloadguix-2812eb2e1b7ec3409cf823c95da1b676259d8698.tar
guix-2812eb2e1b7ec3409cf823c95da1b676259d8698.tar.gz
gnu: Add senpai.
* gnu/packaging/messaging.scm (senpai): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f202837a34..ba8e99065c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3521,4 +3521,57 @@ phone numbers (get validity information, reformat them, or extract numbers from
a text snippet), using @code{libphonenumber}.")
(license license:asl2.0)))
+(define-public senpai
+ (package
+ (name "senpai")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.sr.ht/~taiite/senpai")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qw955i5f3jr42h4afr23v7wq616bcsyq68if75qdw8j1yibnpmb"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~taiite/senpai/cmd/senpai"
+ #:unpack-path "git.sr.ht/~taiite/senpai"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'build-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (invoke "make" "doc/senpai.1" "doc/senpai.5"
+ "-C" (string-append "src/" unpack-path))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (let ((man1 (string-append #$output "/share/man/man1"))
+ (man5 (string-append #$output "/share/man/man5")))
+ (mkdir-p man1)
+ (mkdir-p man5)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.1")
+ man1)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.5")
+ man5)))))))
+ (native-inputs (list go-git-sr-ht-emersion-go-scfg
+ go-github-com-delthas-go-libnp
+ go-github-com-delthas-go-localeinfo
+ go-github-com-gdamore-tcell-v2
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-net
+ go-golang-org-x-term
+ go-golang-org-x-time
+ go-mvdan-cc-xurls
+ scdoc))
+ (home-page "https://sr.ht/~taiite/senpai")
+ (synopsis "Modern terminal IRC client")
+ (description
+ "@code{senpai} is an IRC client that works best with bouncers.")
+ (license license:isc)))
+
;;; messaging.scm ends here