aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-11-08 20:31:40 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-11-11 07:34:54 +0100
commit952d0951da3bc272ac6753631ddc1bd6ee38f03d (patch)
tree0c9694cc0b989cbd11b106dab4380f420d754329 /gnu/packages/mes.scm
parent9ce47b6fdd742324f3e7a47fa09b54f6b613b52f (diff)
downloadguix-952d0951da3bc272ac6753631ddc1bd6ee38f03d.tar
guix-952d0951da3bc272ac6753631ddc1bd6ee38f03d.tar.gz
gnu: mescc-tools: Support riscv64-linux build.
* gnu/packages/mes.scm (mescc-tools) [arguments]: Update to gexps. Add patch-Kaem/test.sh phase to fix shebang for riscv64-linux/qemu build. Change-Id: Id61c04deb08138481f7290607488465710969e8d
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index ba925fe4d1..fa376c9ee8 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages texinfo)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix licenses)
#:use-module (guix packages)
@@ -209,9 +210,8 @@ Guile.")
(version "1.5.0")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/oriansj/mescc-tools/releases/download/"
- "Release_" version "/" name "-" version ".tar.gz"))
+ (uri (string-append "mirror://savannah/" name "/"
+ name "-" version ".tar.gz"))
(sha256
(base32
"1vjczlajyrbjcx9ld35vhdqbxfdwwy3axg0jray3iwnrf70qr700"))))
@@ -220,10 +220,15 @@ Guile.")
"armhf-linux" "aarch64-linux"
"riscv64-linux"))
(arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- (delete 'configure))))
+ (list
+ #:make-flags #~(list (string-append "PREFIX=" #$output))
+ #:test-target "test"
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-Kaem/test.sh
+ (lambda _
+ (substitute* "Kaem/test.sh"
+ (("#/usr/") "#! /usr")))))))
(native-inputs (list which))
(synopsis "Tools for the full source bootstrapping process")
(description