aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-08-06 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-08-13 02:00:00 +0200
commit6048467f0686e1fe9e9bd114e69a5290645f3243 (patch)
treeffe8573e3998476d7d5d5f0f4d22b901665a6a41 /gnu/packages/mc.scm
parent9421890fa24411b9481de5538bcd8d12b9dbcc5c (diff)
downloadguix-6048467f0686e1fe9e9bd114e69a5290645f3243.tar
guix-6048467f0686e1fe9e9bd114e69a5290645f3243.tar.gz
gnu: mc: Use G-expressions.
* gnu/packages/mc.scm (mc)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/mc.scm')
-rw-r--r--gnu/packages/mc.scm81
1 files changed, 41 insertions, 40 deletions
diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 881ed323cd..a80bcd6fae 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix licenses)
#:use-module (guix packages))
@@ -47,6 +48,46 @@
(sha256
(base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "--with-screen=ncurses"
+ "--enable-aspell")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'patch-FHS-file-names
+ (lambda _
+ ;; Patch files to refer to executables in the store or $PATH.
+ (substitute* "misc/mcedit.menu.in"
+ (("#! /bin/sh") (string-append "#!" (which "sh")))
+ (("/bin/bash") (which "bash")))
+ (substitute* "misc/ext.d/misc.sh.in"
+ (("/bin/cat") "cat"))
+ (substitute* (list "lib/utilunix.c"
+ "src/usermenu.c"
+ "src/vfs/fish/fish.c"
+ "tests/src/vfs/extfs/helpers-list/Makefile.in")
+ (("/bin/sh") (which "sh")))
+ (substitute* "src/filemanager/ext.c"
+ (("/bin/rm") "rm")
+ (("/bin/sh") (which "sh")))
+
+ ;; There are other /bin/<shell>s hard-coded in this file, but they
+ ;; are never tried after bash (mc's first choice) is found.
+ (substitute* "lib/shell.c"
+ (("/bin/bash") (which "bash")))))
+ (add-before 'check 'fix-tests
+ (lambda _
+ ;; Don't expect a UID or GID of ‘0’ in the build environment.
+ (with-directory-excursion "tests/src/vfs/extfs/helpers-list/data"
+ (substitute* (list "rpm.custom.output"
+ "rpm.glib.output")
+ ((" 0 0") "<<uid>> <<gid>>")))
+ ;; XXX ERROR:mc_realpath.c:99:realpath_test: assertion failed
+ ;; (resolved_path == data->expected_string): ("" == "/usr/bin")
+ (substitute* "tests/lib/mc_realpath.c"
+ (("/usr/bin") "/")
+ (("usr/bin") "/")))))))
(native-inputs (list perl pkg-config))
(inputs (list aspell
check
@@ -55,46 +96,6 @@
libssh2
ncurses
unzip))
- (arguments
- `(#:configure-flags
- '("--with-screen=ncurses" "--enable-aspell")
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-source-shebangs 'patch-FHS-file-names
- (lambda _
- ;; Patch files to refer to executables in the store or $PATH.
- (substitute* "misc/mcedit.menu.in"
- (("#! /bin/sh") (string-append "#!" (which "sh")))
- (("/bin/bash") (which "bash")))
- (substitute* "misc/ext.d/misc.sh.in"
- (("/bin/cat") "cat"))
- (substitute* (list "lib/utilunix.c"
- "src/usermenu.c"
- "src/vfs/fish/fish.c"
- "tests/src/vfs/extfs/helpers-list/Makefile.in")
- (("/bin/sh") (which "sh")))
- (substitute* "src/filemanager/ext.c"
- (("/bin/rm") "rm")
- (("/bin/sh") (which "sh")))
-
- ;; There are other /bin/<shell>s hard-coded in this file, but they
- ;; are never tried after bash (mc's first choice) is found.
- (substitute* "lib/shell.c"
- (("/bin/bash") (which "bash")))
- #t))
- (add-before 'check 'fix-tests
- (lambda _
- ;; Don't expect a UID or GID of ‘0’ in the build environment.
- (with-directory-excursion "tests/src/vfs/extfs/helpers-list/data"
- (substitute* (list "rpm.custom.output"
- "rpm.glib.output")
- ((" 0 0") "<<uid>> <<gid>>")))
- ;; XXX ERROR:mc_realpath.c:99:realpath_test: assertion failed
- ;; (resolved_path == data->expected_string): ("" == "/usr/bin")
- (substitute* "tests/lib/mc_realpath.c"
- (("/usr/bin") "/")
- (("usr/bin") "/"))
- #t)))))
(home-page "https://www.midnight-commander.org")
(properties
`((release-monitoring-url . "https://ftp.osuosl.org/pub/midnightcommander/")))