aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-03-11 12:07:03 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-04 16:18:14 +0200
commitda7f5916193e903d7205f5221d32a8d214f2db5a (patch)
tree97d91fb84c0accac5e920943fe6ae779a6bfd68d /gnu/packages/maths.scm
parent8e9b803db245e5db42d4cb168cb7071aa77d1751 (diff)
downloadguix-da7f5916193e903d7205f5221d32a8d214f2db5a.tar
guix-da7f5916193e903d7205f5221d32a8d214f2db5a.tar.gz
gnu: superlu-dist: Remove dependency on lapack.
* gnu/packages/maths.scm (superlu-dist): Remove dependency on lapack. Change-Id: I5893e16f7ef6fd688fd6b53eba6d3005b832f0ef Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6ad503b113..0c32aeb69a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4445,7 +4445,6 @@ void mc64ad_dist (int *a, int *b, int *c, int *d, int *e, double *f, int *g,
(inputs
`(("gfortran" ,gfortran)
("blas" ,openblas)
- ("lapack" ,lapack)
("combblas" ,combinatorial-blas)))
(propagated-inputs
`(("mpi" ,openmpi) ;headers include MPI heades
@@ -4456,7 +4455,7 @@ void mc64ad_dist (int *a, int *b, int *c, int *d, int *e, double *f, int *g,
#:configure-flags (list "-DBUILD_SHARED_LIBS:BOOL=YES"
"-DTPL_ENABLE_COMBBLASLIB=YES"
"-DTPL_BLAS_LIBRARIES=-lopenblas"
- "-DTPL_LAPACK_LIBRARIES=-llapack"
+ "-DTPL_LAPACK_LIBRARIES=-lopenblas"
(string-append "-DTPL_PARMETIS_LIBRARIES="
(string-join
'("ptscotchparmetis" "ptscotch" "ptscotcherr"