aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-03-05 10:10:16 +0100
committerLudovic Courtès <ludo@gnu.org>2024-03-19 17:31:32 +0100
commitb213afbf582222cf8865c17285abece3ef8f6e15 (patch)
treefe6c2ea54ea12819847ea76b09aad1ebdf278113 /gnu/packages/maths.scm
parent74533133d3cae3c3f97b3e433920877159522d38 (diff)
downloadguix-b213afbf582222cf8865c17285abece3ef8f6e15.tar
guix-b213afbf582222cf8865c17285abece3ef8f6e15.tar.gz
gnu: combinatorial-blas: Skip failing tests.
* gnu/packages/maths.scm (combinatorial-blas): Add new phase. Change-Id: Ifefb2b17e6758547d38290753a7cd338032a6abb Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d551b751e6..1b4d325649 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8094,6 +8094,12 @@ easily be incorporated into existing simulation codes.")
#:parallel-tests? #f ;tests use 'mpiexec -n4'
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; Skip failing tests (SIGFPE and SIGSEGV).
+ (substitute* "ReleaseTests/CMakeLists.txt"
+ (("^.*SpAsgnTest.*$") "")
+ (("^.*IndexingTest.*$") ""))))
(add-before 'check 'mpi-setup
,%openmpi-setup)
(add-before 'check 'test-setup