aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-29 15:45:30 +0200
committerLudovic Courtès <ludo@gnu.org>2024-09-05 10:14:24 +0200
commit8d5d66887e825a0cbc40030b4d07b0eee92af573 (patch)
tree4d8a65ce7a6cd3fcffa71bef3896990d6ac872ad /gnu/packages/maths.scm
parent0b6586a2237ed45bc07578ecc0d6e74cbd62f8cb (diff)
downloadguix-8d5d66887e825a0cbc40030b4d07b0eee92af573.tar
guix-8d5d66887e825a0cbc40030b4d07b0eee92af573.tar.gz
gnu: petsc: Make ‘petscvariables’ reproducible.
This is a followup to 31fe177a97bacec643180cc5bcf8805a6cb07481. * gnu/packages/maths.scm (petsc)[arguments]: In ‘clean-local-references’, fix typo in ‘MAKE_NP’ and ‘NPMAX’ regexps. Substitute ‘MAKE_TEST_NP’ and ‘MAKE_LOAD’ as well. Change-Id: I41b4279a3cdc4b077fab21f0f99273d0d50ed8e1
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 39c9c18922..dffe7c4ea6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3589,8 +3589,10 @@ September 2004}")
"Machine characteristics: Linux-x.x.x"))
(substitute* (find-files "." "petscvariables")
;; Do not expose build machine characteristics, set to defaults.
- (("MAKE_NP = [:digit:]+") "MAKE_NP = 2")
- (("NPMAX = [:digit:]+") "NPMAX = 2")))))
+ (("MAKE_NP = [[:digit:]]+") "MAKE_NP = 2")
+ (("MAKE_TEST_NP = [[:digit:]]+") "MAKE_TEST_NP = 2")
+ (("MAKE_LOAD = .*") "MAKE_LOAD = 256.0\n")
+ (("NPMAX = [[:digit:]]+") "NPMAX = 2")))))
(add-after 'install 'clean-install
;; Try to keep installed files from leaking build directory names.
(lambda* (#:key inputs outputs #:allow-other-keys)