aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLars Bilke <lars.bilke@ufz.de>2024-03-08 10:49:20 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-03-12 13:48:32 +0200
commit6cff29fb6e273e4a746dd518a07776d7c4c71b42 (patch)
tree5f769d44433d8a1ab931dbb8a8f643a8298c0b22 /gnu/packages/maths.scm
parentac74586ff355df5e14242a5ad0bad23ede23a36e (diff)
downloadguix-6cff29fb6e273e4a746dd518a07776d7c4c71b42.tar
guix-6cff29fb6e273e4a746dd518a07776d7c4c71b42.tar.gz
gnu: petsc: Add tunable property.
Tested with some real-world simulations on multpiple HPC systems. * gnu/packages/maths.scm (petsc)[properties]: Add tunable? flag. Change-Id: I81588d0556c4176f29d7ab760322cd7aec271f12 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ea42341c41..bb2d7a3504 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3515,7 +3515,8 @@ September 2004}")
data structures and routines for the scalable (parallel) solution of
scientific applications modeled by partial differential equations.")
(license (license:non-copyleft
- "https://www.mcs.anl.gov/petsc/documentation/copyright.html"))))
+ "https://www.mcs.anl.gov/petsc/documentation/copyright.html"))
+ (properties '((tunable? . #t)))))
(define-public petsc-complex
(package