aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-04-10 09:15:14 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-01 23:45:24 +0200
commit4dec5a30fe9fc7c93618d42bed4fd69b61b8c6a0 (patch)
tree7991955b900942eddde4f153cb78af5484be4ecd /gnu/packages/maths.scm
parentdf1a6c725939ae5ff026f6a4333d7aa94608430d (diff)
downloadguix-4dec5a30fe9fc7c93618d42bed4fd69b61b8c6a0.tar
guix-4dec5a30fe9fc7c93618d42bed4fd69b61b8c6a0.tar.gz
gnu: scilab: Fixup and improve compilerDetection.sh script.
* gnu/packages/maths.scm (scilab) [arguments]<#:phases>: Fix compilerDetection.sh script in phase bootstrap-dynamic_link-scripts. [source]<origin>(patches): Add scilab-better-compiler-detection.patch. * gnu/packages/patches/scilab-better-compiler-detection.patch: Add file. * gnu/local.mk(dist_path_DATA): Add scilab-better-compiler-detection.patch. Change-Id: I7b1c78c4637fa1bc965eca8c516bf0b6cd4b92d1 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3ce67cc0ba..95bc041e8c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9724,6 +9724,7 @@ computation is supported via MPI.")
(sha256
(base32
"08nyfli3x7gd396ffd1a8zn9fj3gm6a8yw0ggm547c09sp2rgvl7"))
+ (patches (search-patches "scilab-better-compiler-detection.patch"))
(modules '((guix build utils)
(ice-9 ftw)))
(snippet
@@ -9884,7 +9885,11 @@ computation is supported via MPI.")
(add-after 'bootstrap 'bootstrap-dynamic_link-scripts
(lambda _
(with-directory-excursion "modules/dynamic_link/src/scripts"
- ((assoc-ref %standard-phases 'bootstrap)))))
+ ((assoc-ref %standard-phases 'bootstrap))
+ (substitute* "compilerDetection.sh"
+ (("PATHTOCONFIGURE=.*")
+ "PATHTOCONFIGURE=${BASH_SOURCE[0]%/*}/\n")
+ (("PROGNAME.*") "\n")))))
(add-before 'build 'pre-build
(lambda* (#:key inputs #:allow-other-keys)
;; Fix core.start.