aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-05 16:44:52 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-05 22:42:25 +0100
commitefbaa5fcc8caeae7228c8f06c13879e7e920f5ea (patch)
tree60f8814a10096673cbdf98ba49f3a3f68c012866 /gnu/packages/mate.scm
parentc19f968cbd189ae4b7c2d0dba1c2040f1c560c2c (diff)
downloadguix-efbaa5fcc8caeae7228c8f06c13879e7e920f5ea.tar
guix-efbaa5fcc8caeae7228c8f06c13879e7e920f5ea.tar.gz
gnu: mate: Depend on 'librsvg-for-system'.
* gnu/packages/mate.scm (engrampa)[inputs]: Replace LIBRSVG by LIBRSVG-FOR-SYSTEM. (libmatekbd)[inputs]: Likewise. (mate-panel)[inputs]: Likewise. (mate-screensaver)[inputs]: Likewise. (mate-utils)[inputs]: Likewise. (mate-control-center)[inputs]: Likewise. (eom)[inputs]: Likewise, and remove duplicate [license]: Remove unnecessary list.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 7f1c87f46a..c1c24afea4 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -473,7 +473,7 @@ sound systems.")
("gobject-introspection" ,gobject-introspection)))
(inputs
`(("cairo" ,cairo)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("glib" ,glib)
("gtk+" ,gtk+)
("libx11" ,libx11)
@@ -685,7 +685,7 @@ mate-volume-control, a MATE volume control application and applet.")
("libcanberra" ,libcanberra)
("libice" ,libice)
("libmateweather" ,libmateweather)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("libsm" ,libsm)
("libx11" ,libx11)
("libxau" ,libxau)
@@ -983,8 +983,7 @@ icons on the MATE desktop. It works on local and remote file systems.")
("polkit" ,polkit)
("startup-notification" ,startup-notification)))
(propagated-inputs
- `(("librsvg" ,librsvg) ; mate-slab.pc
- ("librsvg" ,librsvg))) ; mate-slab.pc
+ `(("librsvg" ,(librsvg-for-system)))) ;mate-slab.pc
(home-page "https://mate-desktop.org/")
(synopsis "MATE Desktop configuration tool")
(description
@@ -1219,7 +1218,7 @@ Re-decorates windows on un-maximise.
("dbus-glib" ,dbus-glib)
("glib" ,glib)
("gtk+" ,gtk+)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("libcanberra" ,libcanberra)
("libglade" ,libglade)
("libmatekbd" ,libmatekbd)
@@ -1271,7 +1270,7 @@ can be used as backgrounds in the MATE Desktop environment.")
("cairo" ,cairo)
("glib" ,glib)
("gtk+" ,gtk+)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("libcanberra" ,libcanberra)
("libgtop" ,libgtop)
("libx11" ,libx11)
@@ -1324,7 +1323,6 @@ can be used as backgrounds in the MATE Desktop environment.")
("exempi" ,exempi)
("glib" ,glib)
("gtk+" ,gtk+)
- ("librsvg" ,librsvg)
("libcanberra" ,libcanberra)
("libx11" ,libx11)
("libxext" ,libxext)
@@ -1332,7 +1330,7 @@ can be used as backgrounds in the MATE Desktop environment.")
("libxml2" ,libxml2)
("libexif" ,libexif)
("libjpeg" ,libjpeg-turbo)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("lcms" ,lcms)
("mate-desktop" ,mate-desktop)
("pango" ,pango)
@@ -1343,7 +1341,7 @@ can be used as backgrounds in the MATE Desktop environment.")
(synopsis "Eye of MATE")
(description
"Eye of MATE is the Image viewer for the MATE Desktop.")
- (license (list license:gpl2))))
+ (license license:gpl2)))
(define-public engrampa
(package
@@ -1384,7 +1382,7 @@ can be used as backgrounds in the MATE Desktop environment.")
("file" ,file)
("glib" ,glib)
("gtk+" ,gtk+)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("json-glib" ,json-glib)
("libcanberra" ,libcanberra)
("libx11" ,libx11)
@@ -1476,7 +1474,7 @@ can be used as backgrounds in the MATE Desktop environment.")
("libxml2" ,libxml2)
("libwnck" ,libwnck)
("libgtop" ,libgtop)
- ("librsvg" ,librsvg)
+ ("librsvg" ,(librsvg-for-system))
("polkit" ,polkit)))
(home-page "https://mate-desktop.org/")
(synopsis "System Monitor for MATE")