aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-03-28 13:38:34 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:40 +0200
commite3178b088a39e88e784ce6bac5785b414b808514 (patch)
treea85bab142e091c9d57b031fa1b2c8c85a9a9c224 /gnu/packages/mate.scm
parent17e6ce2f8853a37a773fcc6ce3074382327bcb8a (diff)
downloadguix-e3178b088a39e88e784ce6bac5785b414b808514.tar
guix-e3178b088a39e88e784ce6bac5785b414b808514.tar.gz
gnu: Use 'gtk-doc/stable' in native-inputs instead of 'gtk-doc'.
Commit 9dea1618755891526f708aa335b4136c1302d16e only replaced 'gtk-doc' with 'gtk-doc/stable' in the native-inputs of some packages, but we may as well do this for all packages. * gnu/packages/admin.scm (thermald) [native-inputs]: Replace 'gtk-doc' with 'gtk-doc/stable'. * gnu/packages/glib.scm (glib-with-documentation): Likewise. * gnu/packages/mate.scm (mate-desktop, atril, caja-extensions) (mate-utils, eom, engrampa, pluma, mate-polkit) [native-inputs]: Likewise. * gnu/packages/messaging.scm (libgnt, loudmouth) [native-inputs]: Likewise. * gnu/packages/music.scm (denemo, gsequencer) [native-inputs]: Likewise. * gnu/packages/photo.scm (entangle) [native-inputs]: Likewise. * gnu/packages/security-token.scm (libu2f-host, libu2f-server) [native-inputs]: Likewise. * gnu/packages/wm.scm (keybinder, keybinder-3.0) [native-inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I6c647ff1394e0a48bef0e6fb1ae43533673f1d79
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm55
1 files changed, 29 insertions, 26 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index a693156d2b..f83d26b26b 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -241,7 +242,7 @@ themes for both gtk+-2 and gtk+-3.")
`(,glib "bin")
gobject-introspection
yelp-tools
- gtk-doc))
+ gtk-doc/stable))
(inputs
(list gtk+ libxrandr iso-codes startup-notification))
(propagated-inputs
@@ -736,7 +737,7 @@ infamous 'Wanda the Fish'.")
yelp-tools
(list glib "bin")
gobject-introspection
- gtk-doc
+ gtk-doc/stable
texlive-bin ;synctex
libxml2
zlib))
@@ -882,25 +883,27 @@ icons on the MATE desktop. It works on local and remote file systems.")
(string-append "--with-cajadir="
(assoc-ref %outputs "out")
"/lib/caja/extensions-2.0/"))))
- (native-inputs `(("intltool" ,intltool)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc)
- ("libxml2" ,libxml2)
- ("pkg-config" ,pkg-config)))
- (inputs (list attr
- brasero
- caja
- dbus
- dbus-glib
- gajim ;runtime only?
- gst-plugins-base
- gtk+
- graphicsmagick
- mate-desktop
- pidgin ;runtime only?
- startup-notification))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc/stable)
+ ("libxml2" ,libxml2)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ (list attr
+ brasero
+ caja
+ dbus
+ dbus-glib
+ gajim ;runtime only?
+ gst-plugins-base
+ gtk+
+ graphicsmagick
+ mate-desktop
+ pidgin ;runtime only?
+ startup-notification))
(home-page "https://mate-desktop.org/")
(synopsis "Extensions for the File manager Caja")
(description
@@ -1257,7 +1260,7 @@ can be used as backgrounds in the MATE Desktop environment.")
(list #:parallel-build? #f))
(native-inputs
(list gettext-minimal
- gtk-doc
+ gtk-doc/stable
intltool
libice
libsm
@@ -1311,7 +1314,7 @@ can be used as backgrounds in the MATE Desktop environment.")
(build-system glib-or-gtk-build-system)
(native-inputs
(list gettext-minimal
- gtk-doc
+ gtk-doc/stable
gobject-introspection
intltool
pkg-config
@@ -1375,7 +1378,7 @@ can be used as backgrounds in the MATE Desktop environment.")
#t)))))
(native-inputs
`(("gettext" ,gettext-minimal)
- ("gtk-doc" ,gtk-doc)
+ ("gtk-doc" ,gtk-doc/stable)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("yelp-tools" ,yelp-tools)))
@@ -1415,7 +1418,7 @@ can be used as backgrounds in the MATE Desktop environment.")
#:tests? #f))
(native-inputs
`(("gettext" ,gettext-minimal)
- ("gtk-doc" ,gtk-doc)
+ ("gtk-doc" ,gtk-doc/stable)
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("libtool" ,libtool)
@@ -1499,7 +1502,7 @@ MATE Desktop to monitor your system resources and usage.")
"1s2ac2p5smiwr7lf4snciyb9waclychjmzrw32f2qspdm381s2im"))))
(build-system glib-or-gtk-build-system)
(native-inputs
- (list gettext-minimal gtk-doc intltool libtool pkg-config))
+ (list gettext-minimal gtk-doc/stable intltool libtool pkg-config))
(inputs
(list accountsservice
glib