aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorSkylar Chan <schan12@umd.edu>2023-10-31 20:36:27 -0400
committerChristopher Baines <mail@cbaines.net>2023-11-03 10:14:06 +0000
commit6ae8fd7aa7a843ea831b24b74c9d3f7ea3ff49a9 (patch)
tree95bab01e42366abd23718d241050316c3716483a /gnu/packages/markup.scm
parent021b222cda8c33001f8c4823d4abbd7e6afa837e (diff)
downloadguix-6ae8fd7aa7a843ea831b24b74c9d3f7ea3ff49a9.tar
guix-6ae8fd7aa7a843ea831b24b74c9d3f7ea3ff49a9.tar.gz
gnu: cmark-gfm: Update to 0.29.0.gfm.13.
* gnu/packages/markup.scm (cmark-gfm): Update to 0.29.0.gfm.13. [arguments]: Use G-expressions. Change-Id: Id8f856cfa8020bc8028d9bf3041a7c651b8b0102 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index ad2d74f742..6ee7bebf57 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -391,7 +391,7 @@ CommonMark C library libcmark. It closely follows the original API.")
(package
(inherit cmark)
(name "cmark-gfm")
- (version "0.29.0.gfm.2")
+ (version "0.29.0.gfm.13")
(home-page "https://github.com/github/cmark-gfm")
(source (origin
(method git-fetch)
@@ -399,16 +399,15 @@ CommonMark C library libcmark. It closely follows the original API.")
(file-name (git-file-name name version))
(sha256
(base32
- "0vz6zs3m22k7jzfj4782lahciwfjlbi4m3qz5crsmssip3rwdy7h"))))
+ "1apy9i76rgs0bmgdlpjszv0fpqhlap2s12m68wvnsv8j3fsqc90y"))))
(arguments
- '(#:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-after 'install 'install-config
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; XXX: cmark-gfm-core-extensions.h includes this file.
- (install-file "src/config.h"
- (string-append out "/include"))))))))
+ (list #:test-target "test"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-config
+ (lambda _
+ ;; XXX: cmark-gfm-core-extensions.h includes this file.
+ (install-file "src/config.h"
+ (string-append #$output "/include")))))))
(synopsis "GitHub flavored CommonMark")
(description
"This package is a fork of @code{cmark}, with GitHub-specific Markdown