aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-11-11 19:30:53 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-11-25 14:47:51 +0100
commit5edc8bec3022663d960820d34022764aed8284a2 (patch)
tree6172be310969d857bbee479f0196897855dee048 /gnu/packages/markup.scm
parent06c1301aa2e4f2f9d9679695b11c61093235c1cc (diff)
downloadguix-5edc8bec3022663d960820d34022764aed8284a2.tar
guix-5edc8bec3022663d960820d34022764aed8284a2.tar.gz
gnu: smu: Fix cross-compilation.
* gnu/packages/markup.scm (smu): Fix cross-compilation. [arguments]: Use Gexp and CC-FOR-TARGET. Change-Id: Ifb6a1962b12b31ed0092cb042670301a3ef4cfa8 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 595b08fa20..4a9a382104 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -428,13 +429,13 @@ additions.")))
(base32 "1jm7lhnzjx4q7gcwlkvsbffcy0zppywyh50d71ami6dnq182vvcc"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:tests? #f ; no tests included
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://github.com/Gottox/smu")
(synopsis "Simple markup")
(description