aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-11 13:50:30 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:23 +0200
commit77ee97628a2d126a31f60d4ca8fafa70a66be804 (patch)
tree9565b13511fe4bd981d5990903612e8e0e02fe34 /gnu/packages/make-bootstrap.scm
parentf9f2198d82f6aa7147700bed3f9d42a93201d620 (diff)
downloadguix-77ee97628a2d126a31f60d4ca8fafa70a66be804.tar
guix-77ee97628a2d126a31f60d4ca8fafa70a66be804.tar.gz
gnu: binutils: Use gexps.
This is the result of applying ‘guix style -S arguments’ and making small adjustments. * gnu/packages/base.scm (binutils)[arguments]: Use gexps. (binutils-2.33, binutils-gold): Likewise. * gnu/packages/commencement.scm (binutils-mesboot0, binutils-mesboot1) (binutils-boot0, binutils-final): Likewise. * gnu/packages/cross-base.scm (cross-binutils*): Adjust accordingly. * gnu/packages/embedded.scm (make-propeller-binutils): Use gexps. * gnu/packages/make-bootstrap.scm (%binutils-static): Use gexps. Change-Id: I59cbe29760784b09e6d4e80beca9153cb9b495a7
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm50
1 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 1b5939b952..7dc1743aea 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -375,32 +375,34 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define %binutils-static
;; Statically-linked Binutils.
- (package (inherit binutils)
+ (package
+ (inherit binutils)
(name "binutils-static")
(arguments
- `(#:configure-flags (cons "--disable-gold"
- ,(match (memq #:configure-flags
- (package-arguments binutils))
- ((#:configure-flags flags _ ...)
- flags)))
- #:make-flags ,(match (memq #:make-flags (package-arguments binutils))
- ((#:make-flags flags _ ...)
- flags)
- (_ ''()))
- #:strip-flags '("--strip-all")
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'all-static
- (lambda _
- ;; The `-all-static' libtool flag can only be passed
- ;; after `configure', since configure tests don't use
- ;; libtool, and only for executables built with libtool.
- (substitute* '("binutils/Makefile.in"
- "gas/Makefile.in"
- "ld/Makefile.in")
- (("^LDFLAGS =(.*)$" line)
- (string-append line
- "\nAM_LDFLAGS = -static -all-static\n")))
- #t)))))))
+ (list #:configure-flags
+ #~(cons "--disable-gold"
+ #$(match (memq #:configure-flags (package-arguments binutils))
+ ((#:configure-flags flags _ ...)
+ flags)))
+ #:make-flags
+ (match (memq #:make-flags (package-arguments binutils))
+ ((#:make-flags flags _ ...)
+ flags)
+ (_ #~'()))
+ #:strip-flags #~'("--strip-all")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'all-static
+ (lambda _
+ ;; The `-all-static' libtool flag can only be passed after
+ ;; `configure', since configure tests don't use libtool,
+ ;; and only for executables built with libtool.
+ (substitute* '("binutils/Makefile.in"
+ "gas/Makefile.in" "ld/Makefile.in")
+ (("^LDFLAGS =(.*)$" line)
+ (string-append
+ line
+ "\nAM_LDFLAGS = -static -all-static\n"))))))))))
(define %binutils-static-stripped
;; The subset of Binutils that we need.