aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-09-12 10:49:55 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-02-15 09:13:34 +0100
commit0501136d57dc47336d0ac4e5f59a67865b40b598 (patch)
tree64e5ed994bec39e969036ea3579f56aa8aac07e4 /gnu/packages/make-bootstrap.scm
parentccb55481d4072b21d827e4a71e166956bc1a4e25 (diff)
downloadguix-0501136d57dc47336d0ac4e5f59a67865b40b598.tar
guix-0501136d57dc47336d0ac4e5f59a67865b40b598.tar.gz
gnu: bootstrap: mescc-tools-static: Remove packages and tarball.
* gnu/packages/make-bootstrap.scm (%mescc-tools-static, %mescc-tools-static-stripped, %mescc-tools-bootstrap-tarball): Remove.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 64e7db552d..34edabfe41 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -53,7 +53,6 @@
%glibc-bootstrap-tarball
%gcc-bootstrap-tarball
%guile-bootstrap-tarball
- %mescc-tools-bootstrap-tarball
%mes-bootstrap-tarball
%bootstrap-tarballs
@@ -595,43 +594,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
'("gcc" "g++" "cpp"))))))))))
;; Two packages: first build static, bare minimum content.
-(define %mescc-tools-static
- ;; A statically linked MesCC Tools.
- (package
- (inherit mescc-tools)
- (name "mescc-tools-static")
- (arguments
- `(#:system "i686-linux"
- ,@(substitute-keyword-arguments (package-arguments mescc-tools)
- ((#:make-flags flags)
- `(cons "CC=gcc -static" ,flags)))))))
-
-;; ... next remove store references.
-(define %mescc-tools-static-stripped
- ;; A statically linked Mescc Tools with store references removed, for
- ;; bootstrap.
- (package
- (inherit %mescc-tools-static)
- (name (string-append (package-name %mescc-tools-static) "-stripped"))
- (build-system trivial-build-system)
- (arguments
- (list #:modules '((guix build utils))
- #:builder
- #~(begin
- (use-modules (guix build utils))
- (let* ((in #$%mescc-tools-static)
- (out #$output)
- (bin (string-append out "/bin")))
- (mkdir-p bin)
- (for-each (lambda (file)
- (let ((target (string-append bin "/" file)))
- (format #t "copying `~a'...~%" file)
- (copy-file (string-append in "/bin/" file)
- target)
- (remove-store-references target)))
- '( "M1" "blood-elf" "hex2"))))))))
-
-;; Two packages: first build static, bare minimum content.
(define-public %mes-minimal
;; A minimal Mes without documentation.
(package
@@ -871,10 +833,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; A tarball with the statically-linked, relocatable Guile.
(tarball-package %guile-static-stripped))
-(define %mescc-tools-bootstrap-tarball
- ;; A tarball with statically-linked MesCC binary seed.
- (tarball-package %mescc-tools-static-stripped))
-
(define %mes-bootstrap-tarball
;; A tarball with Mes binary seed.
(tarball-package %mes-minimal-stripped))