aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-23 10:01:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-29 16:19:24 +0300
commitbf2370a52576bd77cf944229a8003d4dfb2c99bf (patch)
tree28c37d0365e523fe8481c6591160e6e829a89224 /gnu/packages/mail.scm
parent5bda3f8a3424adb7c677f349bd5b6e639eb18673 (diff)
downloadguix-bf2370a52576bd77cf944229a8003d4dfb2c99bf.tar
guix-bf2370a52576bd77cf944229a8003d4dfb2c99bf.tar.gz
gnu: fetchmail: Wrap fetchmailconf.
* gnu/packages/mail.scm (fetchmail)[arguments]: Add a phase to wrap fetchmailconf with GUIX_PYTHONPATH. [inputs]: Add bash-minimal, python-future, python-wrapper. Change-Id: I6f48361e7d739bfcaa2d1f20eb177933e5e7a5d8
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 52ac86dfbd..e4316831d0 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -633,9 +633,20 @@ to run without any changes.")
(arguments
(list #:configure-flags
#~(list (string-append "--with-ssl="
- #$(this-package-input "openssl")))))
+ #$(this-package-input "openssl")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-fetchmailconf
+ (lambda _
+ (wrap-program (string-append #$output "/bin/fetchmailconf")
+ `("GUIX_PYTHONPATH" ":"
+ prefix (,(getenv "GUIX_PYTHONPATH")))))))))
(inputs
- (list openssl))
+ (list openssl
+ ;; Needed for fetchmailconf
+ bash-minimal
+ python-future
+ python-wrapper))
(home-page "https://www.fetchmail.info/")
(synopsis "Remote-mail retrieval and forwarding utility")
(description