aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-08-04 22:15:53 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-06 11:46:25 +0200
commit852c75a125273f4d3c3e540497f3b5e825468362 (patch)
tree1ae0f231bd4ca14c7096f31a99f517d12f8bd288 /gnu/packages/machine-learning.scm
parent95cec3af47d9fa06f8aee533ce58976bd3dc9d84 (diff)
downloadguix-852c75a125273f4d3c3e540497f3b5e825468362.tar
guix-852c75a125273f4d3c3e540497f3b5e825468362.tar.gz
gnu: Remove onnx-for-torch2.
* gnu/packages/machine-learning.scm (onnx-for-torch2): Delete variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 3e9443506d..c3c5882932 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1417,35 +1417,6 @@ an extensible computation graph model, as well as definitions of built-in
operators and standard data types.")
(license license:expat)))
-(define-public onnx-for-torch2
- (package
- (inherit onnx)
- (name "onnx")
- (version "1.13.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/onnx/onnx")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "16967dbq2j40diqd0s37r19llsab8q8vbxkg1ppgy0p9fpdhfhyp"))
- (file-name (git-file-name name version))
- (patches (search-patches "onnx-1.13.1-use-system-googletest.patch"
- "onnx-shared-libraries.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "third_party")
- (substitute* "onnx/backend/test/runner/__init__.py"
- (("urlretrieve\\(.*") "raise unittest.SkipTest('Skipping download')\n"))))))
- (arguments
- ;; reuse build system tweaks
- (substitute-keyword-arguments (package-arguments onnx)
- ((#:phases phases)
- #~(modify-phases #$phases
- (delete 'relax-requirements)))))))
-
(define-public python-onnx
;; This used to be called "python-onnx" because it provided nothing but
;; Python bindings. The package now provides shared libraries and C++