aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lolcode.scm
diff options
context:
space:
mode:
authorng0 <ngillmann@runbox.com>2016-10-15 21:01:00 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-10-26 20:39:27 +0300
commit5d73e3000030006b00e7e6644f3ced5d6176376e (patch)
treec571a7da73f9b7069353ff3aeb207553031d3729 /gnu/packages/lolcode.scm
parent8caeb11772cc1df06cb6bf227c3280ae6858bd59 (diff)
downloadguix-5d73e3000030006b00e7e6644f3ced5d6176376e.tar
guix-5d73e3000030006b00e7e6644f3ced5d6176376e.tar.gz
gnu: Add lci.
* gnu/packages/lolcode.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/lolcode.scm')
-rw-r--r--gnu/packages/lolcode.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/lolcode.scm b/gnu/packages/lolcode.scm
new file mode 100644
index 0000000000..4c7d18217d
--- /dev/null
+++ b/gnu/packages/lolcode.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lolcode)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages readline)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public lci
+ (package
+ (name "lci")
+ (version "0.11.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/justinmeza/lci/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1li7ikcrs7wqah7gqkirg0k61n6pm12w7pydin966x1sdn9na46b"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("readline" ,readline)))
+ (native-inputs
+ `(("python-2" ,python-2))) ; for the tests
+ (synopsis "LOLCODE interpreter written in C")
+ (description
+ "@code{lci} is a LOLCODE interpreter written in C and is designed to be
+correct, portable, fast, and precisely documented.
+@enumerate
+@item correct: Every effort has been made to test lci's conformance to the
+LOLCODE language specification. Unit tests come packaged with the lci source code.
+@item portable: lci follows the widely ported ANSI C specification allowing it
+to compile on a broad range of systems.
+@item fast: Much effort has gone into producing simple and efficient code
+whenever possible to the extent that the above points are not compromized.
+@end enumerate")
+ (home-page "http://lolcode.org/")
+ (license license:gpl3+)))