aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorykonai <mail@ykonai.net>2023-08-15 21:49:37 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-08-18 11:47:18 +0200
commite53810054ddf93872db48284f548fbfcfa8504f7 (patch)
tree03971e0a0d8c2d11bc80f3ea1884c6ad8a0e163f /gnu/packages/lisp-xyz.scm
parentcb948aef0caae7e9f3b61c57aa06a73be04a5868 (diff)
downloadguix-e53810054ddf93872db48284f548fbfcfa8504f7.tar
guix-e53810054ddf93872db48284f548fbfcfa8504f7.tar.gz
gnu: Add cl-gobject-introspection-wrapper.
* gnu/packages/lisp-xyz.scm (sbcl-cl-gobject-introspection-wrapper, cl-gobject-introspection-wrapper, ecl-cl-gobject-introspection-wrapper): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 74d8cb0ad5..d423cb8399 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
;;; Copyright © 2022, 2023 Artyom Bologov <mail@aartaka.me>
;;; Copyright © 2023 Roman Scherer <roman@burningswell.com>
+;;; Copyright © 2023 ykonai <mail@ykonai.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9607,6 +9608,41 @@ of C+GObject libraries without the need of writing dedicated bindings.")
(define-public ecl-cl-gobject-introspection
(sbcl-package->ecl-package sbcl-cl-gobject-introspection))
+(define-public sbcl-cl-gobject-introspection-wrapper
+ (let ((commit "2d197cba7e7d734ac8a2e181e5e709e5b218bada")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-gobject-introspection-wrapper")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bohonghuang/cl-gobject-introspection-wrapper")
+ (commit commit)))
+ (file-name (git-file-name "cl-gobject-introspection-wrapper" version))
+ (sha256
+ (base32 "05np2zs5806ib6qfz7d6knyaz6llxgwvjqavl1fsz5hcga40296s"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria
+ sbcl-cl-gobject-introspection
+ sbcl-cl-ppcre))
+ (home-page
+ "https://github.com/bohonghuang/cl-gobject-introspection-wrapper")
+ (synopsis
+ "Wrap and call GObject Introspection FFI function in Common Lisp")
+ (description
+ "This library converts the elements from GObject Introspection into
+Common Lisp-style definitions, based on cl-gobject-introspection.")
+ (license license:lgpl3+))))
+
+(define-public cl-gobject-introspection-wrapper
+ (sbcl-package->cl-source-package sbcl-cl-gobject-introspection-wrapper))
+
+(define-public ecl-cl-gobject-introspection-wrapper
+ (sbcl-package->ecl-package sbcl-cl-gobject-introspection-wrapper))
+
(define-public sbcl-cl-slug
(let ((commit "ffb229d10f0d3f7f54e706791725225e200bf749")
(revision "1"))