aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorKarl Hallsby <karl@hallsby.com>2023-10-19 00:06:02 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2023-10-19 14:06:52 +0200
commitc065da01ff956d3c2bdfc45a33d910e509a211d9 (patch)
treeb0467cb6c8c2dfdb0b0f71c7eae4df5ef9af9b43 /gnu/packages/lisp-xyz.scm
parentcbd1c983e1b7bc392287226e44437996cc2cf750 (diff)
downloadguix-c065da01ff956d3c2bdfc45a33d910e509a211d9.tar
guix-c065da01ff956d3c2bdfc45a33d910e509a211d9.tar.gz
gnu: Add cl-wayland.
* gnu/packages/lisp-xyz.scm (sbcl-cl-wayland, cl-wayland, ecl-cl-wayland): New variables. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net> Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 54061cd1a8..1032ce04c9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2174,6 +2174,48 @@ from other CLXes around the net.")
(define-public ecl-clx
(sbcl-package->ecl-package sbcl-clx))
+(define-public sbcl-cl-wayland
+ (let ((commit "a92a5084b64102f538ab90212e99c7863e5338ae")
+ (revision "0"))
+ (package
+ (name "sbcl-cl-wayland")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sdilts/cl-wayland")
+ (commit commit)))
+ (file-name (git-file-name "cl-wayland" version))
+ (sha256
+ (base32 "1r4fn9dc0dz2b30k8z243yacx1y5z21qk4zh2ildj7ak51qx53zf"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "wayland-server-core.lisp"
+ (("libwayland-server.so")
+ (search-input-file inputs
+ "/lib/libwayland-server.so"))))))))
+ (inputs
+ (list sbcl-cffi
+ sbcl-closer-mop
+ wayland))
+ (home-page "https://github.com/sdilts/cl-wayland")
+ (synopsis "Common Lisp FFI bindings for libwayland")
+ (description
+ "This package provides Common Lisp FFI bindings for libwayland,
+primarily for the mahogany window manager.")
+ (license license:bsd-3))))
+
+(define-public cl-wayland
+ (sbcl-package->cl-source-package sbcl-cl-wayland))
+
+(define-public ecl-cl-wayland
+ (sbcl-package->ecl-package sbcl-cl-wayland))
+
(define-public sbcl-clx-truetype
(let ((commit "c6e10a918d46632324d5863a8ed067a83fc26de8")
(revision "1"))