aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGrigory Shepelev <shegeley@gmail.com>2024-10-29 14:55:16 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-10-29 14:56:46 +0100
commit958f9175bde167aa809791501812248d0cc87b92 (patch)
treeaacab77b99eaba3c0df5cb02e236f042506a4e26 /gnu/packages/lisp-xyz.scm
parent714f60d2f7c20c66b9a90794bac3a16f86fd136c (diff)
downloadguix-958f9175bde167aa809791501812248d0cc87b92.tar
guix-958f9175bde167aa809791501812248d0cc87b92.tar.gz
gnu: Add cl-input-event-codes.
* gnu/packages/lisp-xyz.scm (cl-input-event-codes, ecl-cl-input-event-codes, sbcl-cl-input-event-codes): New variables. Change-Id: I47e65729f907e46d9deeb7dc0219ac9b1ba1a291 Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c4d47146c3..90dcbee8d3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18260,6 +18260,38 @@ transcribing mathematical formulas into Lisp.")
(define-public ecl-inheriting-readers
(sbcl-package->ecl-package sbcl-inheriting-readers))
+(define-public sbcl-input-event-codes
+ (package
+ (name "sbcl-input-event-codes")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~shunter/input-event-codes")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-input-event-codes" version))
+ (sha256
+ (base32 "0bygspj84jzyiy06z4q64z1nzsmvvrviqxw73wzqaq2wk2p56vs6"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list pkg-config
+ sbcl-parachute))
+ (inputs
+ (list sbcl-trivial-features))
+ (home-page "https://git.sr.ht/~shunter/input-event-codes")
+ (synopsis "Event codes for Common Lisp")
+ (description
+ "This library is a Common Lisp port of all the constants from the event
+codes header file found on Linux and FreeBSD.")
+ (license license:expat)))
+
+(define-public cl-input-event-codes
+ (sbcl-package->cl-source-package sbcl-input-event-codes))
+
+(define-public ecl-input-event-codes
+ (sbcl-package->ecl-package sbcl-input-event-codes))
+
(define-public sbcl-inquisitor
(let ((commit "423fa9bdd4a68a6ae517b18406d81491409ccae8")
(revision "0"))