aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authornik gaffney <nik@fo.am>2024-03-05 18:14:46 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-03-08 10:16:12 +0100
commit867eb0cfb9cce30b49b309c71f02be4cd5f51c28 (patch)
treecc45b71681819e41f00198b11992805f561b6a57 /gnu/packages/lisp-xyz.scm
parent61ef4d2adb5a30ba98fb37b4a5626f84e08df567 (diff)
downloadguix-867eb0cfb9cce30b49b309c71f02be4cd5f51c28.tar
guix-867eb0cfb9cce30b49b309c71f02be4cd5f51c28.tar.gz
gnu: cl-osc: update to 0.9-0.f647738.
* gnu/packages/lisp-xyz.scm (sbcl-osc): Update to 0.9-0.f647738. [native-inputs]: Add sbcl-fiveam. [inputs]: Remove sbcl-usocket, add sbcl-ieee-floats. [description]: Update it. [license]: Remove llgpl. Change-Id: Iba92207d845101a1c6e57d3676e7bd177127c192 Modified-by: Guillaume Le Vaillant <glv@posteo.net> Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f9c01c94ec..435f588ab3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2023 Raven Hallsby <karl@hallsby.com>
;;; Copyright © 2024 Michal Atlas <michal_atlas+git@posteo.net>
;;; Copyright © 2024 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2024 Nik Gaffney <nik@fo.am>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25731,11 +25732,11 @@ Common Lisp.")
(sbcl-package->ecl-package sbcl-cl-collider))
(define-public sbcl-osc
- (let ((commit "9f0a9d3da310a3a0f654f48af0203816f3f371ad")
+ (let ((commit "f647738ccc22925ed740a8ca9132fda76a05baeb")
(revision "0"))
(package
(name "sbcl-osc")
- (version (git-version "0.7" revision commit))
+ (version (git-version "0.9" revision commit))
(source
(origin
(method git-fetch)
@@ -25744,16 +25745,18 @@ Common Lisp.")
(commit commit)))
(file-name (git-file-name "cl-osc" version))
(sha256
- (base32 "0gh29zcl9pmy3xlmwzpf9www2z06ah6b4jk06sj2cvxbc15nblqa"))))
+ (base32 "1x4cavspaxcr604g0hwak1ncy4m9cqq03ji4v56g2h1443n7h48a"))))
(build-system asdf-build-system/sbcl)
- (inputs (list sbcl-usocket))
+ (native-inputs (list sbcl-fiveam))
+ (inputs (list sbcl-ieee-floats))
(synopsis "Implementation of the Open Sound Control protocol")
- (description "This package provides a common lisp implementation
-of the Open Sound Control Protocol aka OSC. The code should be close
-to the ansi standard, and does not rely on any external code/ffi/etc+
-to do the basic encoding and decoding of packets.")
+ (description "This is a lisp implementation of the Open Sound Control
+protocol (or more accurately “data transport specification” or
+“encoding”). The code should be close to ANSI standard common lisp and
+provides self contained code for encoding and decoding of OSC data, messages,
+and bundles.")
(home-page "https://github.com/zzkt/osc/")
- (license (list license:gpl3 license:llgpl)))))
+ (license license:gpl3+))))
(define-public cl-osc
(sbcl-package->cl-source-package sbcl-osc))