aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorCharles <charles@charje.net>2024-01-28 01:15:05 -0600
committerGuillaume Le Vaillant <glv@posteo.net>2024-01-28 17:23:28 +0100
commit567aa4c7aadc44ee912f288e20e2b2228b7d0c07 (patch)
tree742489478a087d05b5ad9070b93d0d8a6523f369 /gnu/packages/lisp-xyz.scm
parenteea35c32ddc35b0f8d97909dcae6b4c63b195a27 (diff)
downloadguix-567aa4c7aadc44ee912f288e20e2b2228b7d0c07.tar
guix-567aa4c7aadc44ee912f288e20e2b2228b7d0c07.tar.gz
gnu: Add cl-charje.documentation.
* gnu/packages/lisp-xyz.scm (sbcl-charje.documentation, cl-charje.documentation, ecl-charje.documentation): New variables. Change-Id: I635af17de831ccacfb7caa2cfcf84e9da694a3ba Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 83c8a970b9..246b85108d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10530,6 +10530,37 @@ for more information.")
(define-public ecl-documentation-utils-extensions
(sbcl-package->ecl-package sbcl-documentation-utils-extensions))
+(define-public sbcl-charje.documentation
+ (package
+ (name "sbcl-charje.documentation")
+ (version "0.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~charje/documentation")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "149r9qdz5dyxsamhf5miaa9njr7kn7nc0ic448k133rs3nnwagqc"))
+ (file-name (git-file-name "cl-charje.documentation" version))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria))
+ (home-page "https://git.sr.ht/~charje/documentation")
+ (synopsis "Docstring parsing library for Common Lisp")
+ (description "Charje.documentation can used to parse Common Lisp
+docstrings the charje way, or it can be used to create custom docstring
+parsers. Docstring parsers are composed using mixin classes and
+initialization methods.")
+ (license license:agpl3+)))
+
+(define-public cl-charje.documentation
+ (sbcl-package->cl-source-package sbcl-charje.documentation))
+
+(define-public ecl-charje.documentation
+ (sbcl-package->ecl-package sbcl-charje.documentation))
+
(define-public sbcl-staple
(let ((commit "0ee8e25fe6fe8fa83b2a6c93d4febd468c3eaa4e")
(revision "1"))