aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTim Gesthuizen <tim.gesthuizen@yahoo.de>2019-01-05 20:55:14 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-18 10:51:06 +0100
commitbf2a9969a26886a4c57df1a6011f18edd2f013d0 (patch)
treec27220fd9a480b5d6fa8730cfc225f8278b95346 /gnu/packages/linux.scm
parentb6fd086a61b3004f9f5392f630155b9ad01752e1 (diff)
downloadguix-bf2a9969a26886a4c57df1a6011f18edd2f013d0.tar
guix-bf2a9969a26886a4c57df1a6011f18edd2f013d0.tar.gz
gnu: Add inputattach
* gnu/packages/linux.scm (inputattach): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 999caf9ab6..d08784b3f6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2018 Manuel Graf <graf@init.at>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
+;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5188,3 +5189,45 @@ the correct permissions and ownership, and then pack them up, or one would
have to construct the archives directly, without using the archiver.")
(home-page "http://freshmeat.sourceforge.net/projects/fakeroot")
(license license:gpl3+)))
+
+(define-public inputattach
+ (package
+ (name "inputattach")
+ (version "0.42.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxwacom/input-wacom.git")
+ (commit (string-append "input-wacom-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04lnn7v0rm4ppbya140im5d4igcl6c1nrqpgbsr0i8wkral0nv7j"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "inputattach"
+ (invoke (string-append (assoc-ref inputs "gcc")
+ "/bin/gcc")
+ "-o" "inputattach" "inputattach.c"))
+ #t))
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((target-dir (string-append
+ (assoc-ref outputs "out")
+ "/bin/")))
+ (mkdir-p target-dir)
+ (copy-file "inputattach/inputattach"
+ (string-append target-dir
+ "inputattach"))
+ #t))))))
+ (home-page "https://linuxwacom.github.io/")
+ (synopsis "Dispatch input peripherals events to a device file")
+ (description "inputattach dispatches input events from several device
+types and interfaces and translates so that the X server can use them.")
+ (license license:gpl2+)))