aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-10-12 18:59:16 +0200
committerLudovic Courtès <ludo@gnu.org>2024-10-12 19:01:26 +0200
commit30cef697d1cd77580d1cf23e42f6a3a410fd726f (patch)
tree51b0fa8a25bbafec6aa426422e8df374c7a867de /gnu/packages/linux.scm
parent7a89bbffd081129da8c2c5b58b4e12133bf210c5 (diff)
downloadguix-30cef697d1cd77580d1cf23e42f6a3a410fd726f.tar
guix-30cef697d1cd77580d1cf23e42f6a3a410fd726f.tar.gz
gnu: linux-libre: Add ‘timeout’ property.
This changes adds a ‘timeout’ property, which is necessary when building either ‘linux-libre’ or ‘linux-libre-headers’ on aarch64-linux, where deblobbing takes more than 5 hours (the default timeout for Cuirass jobs). * gnu/packages/linux.scm (%linux-libre-timeout-properties): New variable. (make-linux-libre-headers*): Use it. (make-linux-libre*): Likewise. Change-Id: I0c398e06f1b9b1d217fa82493b79bca8589408c0
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 375915bdb3..5888ea470e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -697,6 +697,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;;; Kernel headers.
;;;
+(define %linux-libre-timeout-properties
+ ;; Package properties for 'linux-libre' and 'linux-libre-headers' packages.
+ `((timeout . ,(* 8 3600)) ;deblob takes >5h on AArch64
+ (max-silent-time . ,(* 3 3600)))) ;don't time out on blob scan
+
(define (make-linux-libre-headers version gnu-revision hash-string)
(make-linux-libre-headers* version gnu-revision
(origin
@@ -765,6 +770,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
#:allowed-references ()
#:tests? #f))
(supported-systems (delete "i586-gnu" %supported-systems))
+ (properties %linux-libre-timeout-properties)
(home-page "https://www.gnu.org/software/linux-libre/")
(synopsis "GNU Linux-Libre kernel headers")
(description "Headers of the Linux-Libre kernel.")
@@ -1129,7 +1135,7 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
(description "GNU Linux-Libre is a free (as in freedom) variant of the
Linux kernel. It has been modified to remove all non-free binary blobs.")
(license license:gpl2)
- (properties '((max-silent-time . 10800))))) ;don't timeout on blob scan
+ (properties %linux-libre-timeout-properties)))
;;;