aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-01-08 14:26:43 -0500
committerLeo Famulari <leo@famulari.name>2023-01-08 15:15:09 -0500
commit064c5b7e450f9f6d55cfcd0ec2bc9e96ee0b2958 (patch)
treee97dbb22a14691591aa4a4ba5efff2a13cd355cb /gnu/packages/linux.scm
parent812ecf7ee673a3d619d1d3664350508c67e9d92c (diff)
downloadguix-064c5b7e450f9f6d55cfcd0ec2bc9e96ee0b2958.tar
guix-064c5b7e450f9f6d55cfcd0ec2bc9e96ee0b2958.tar.gz
gnu: Remove linux-libre 4.9.
This kernel series is no longer supported upstream: https://lkml.iu.edu/hypermail/linux/kernel/2301.0/06398.html https://www.kernel.org/category/releases.html * gnu/packages/aux-files/linux-libre/4.9-i686.conf, gnu/packages/aux-files/linux-libre/4.9-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them. * gnu/packages/linux.scm (linux-libre-4.9-version, linux-libre-4.9-gnu-revision, deblob-scripts-4.9, linux-libre-4.9-pristine-source, linux-libre-4.9-source, linux-libre-headers-4.9, linux-libre-4.9): Remove variables. * gnu/tests/base.scm (%test-linux-libre-4.9): Likewise.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ac126cf85d..516f8c8507 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -588,21 +588,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-4.14)))
-(define-public linux-libre-4.9-version "4.9.337")
-(define-public linux-libre-4.9-gnu-revision "gnu1")
-(define deblob-scripts-4.9
- (linux-libre-deblob-scripts
- linux-libre-4.9-version
- linux-libre-4.9-gnu-revision
- (base32 "0nai5m4rbh37qaj1xf2qj7656l2gacfh0847q5d07y22b048fq5n")
- (base32 "0bib3641dbcqdkx3anna3caxnsg3nw9cnmhcklq0s93g3m57041h")))
-(define-public linux-libre-4.9-pristine-source
- (let ((version linux-libre-4.9-version)
- (hash (base32 "1imkn3dbxsr35br79sp9s2r9hy1xqvsm652icbsf6rn7apnam1ak")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-4.9)))
-
(define %boot-logo-patch
;; Linux-Libre boot logo featuring Freedo and a gnu.
(origin
@@ -671,10 +656,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(source-with-patches linux-libre-4.14-pristine-source
(list %boot-logo-patch)))
-(define-public linux-libre-4.9-source
- (source-with-patches linux-libre-4.9-pristine-source
- (list %boot-logo-patch)))
-
;;;
;;; Kernel headers.
@@ -787,11 +768,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-4.14-gnu-revision
linux-libre-4.14-source))
-(define-public linux-libre-headers-4.9
- (make-linux-libre-headers* linux-libre-4.9-version
- linux-libre-4.9-gnu-revision
- linux-libre-4.9-source))
-
;; The following package is used in the early bootstrap, and thus must be kept
;; stable and with minimal build requirements.
(define-public linux-libre-headers-5.10.35
@@ -1159,13 +1135,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
"powerpc64le-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-4.9
- (make-linux-libre* linux-libre-4.9-version
- linux-libre-4.9-gnu-revision
- linux-libre-4.9-source
- '("x86_64-linux" "i686-linux" "powerpc64le-linux")
- #:configuration-file kernel-config))
-
;; Linux-Libre-LTS points to the *newest* released long-term support version of
;; Linux-Libre.
;; Reference: https://jxself.org/linux-libre/