aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/librewolf.scm
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-09-23 07:47:06 -0700
committerAndrew Tropin <andrew@trop.in>2024-09-24 11:03:23 +0400
commit8888f930ad9b2494a23e88019284266a1b1b2bb0 (patch)
treea6da022be3dbf217ed0bf53554bc0b79c29529dd /gnu/packages/librewolf.scm
parentaa250f071a89a7a06bbb453325240a9d4a59c2a9 (diff)
downloadguix-8888f930ad9b2494a23e88019284266a1b1b2bb0.tar
guix-8888f930ad9b2494a23e88019284266a1b1b2bb0.tar.gz
gnu: librewolf-source: Turn into a procedure.
This patch changes the `librewolf-source' variable into the `make-librewolf-source' prodecure. This procedure accepts a LibreWolf version, source hash, and Firefox source hash. The Firefox source version is derived from the provided LibreWolf version. This eases package updates, since the hashes are inside the `librewolf' package, rather than `librewolf-source'; and the version no longer needs to be specified in three places. It also removes a blank line between the file header and `define-module'. * gnu/packages/librewolf.scm (librewolf-source): Turn into a procedure. Change-Id: I96ab1304acde246c179e7aa5dad9ff621be3de82 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/librewolf.scm')
-rw-r--r--gnu/packages/librewolf.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index bade479656..6fd0aa51f1 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -40,7 +40,6 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
(define-module (gnu packages librewolf)
#:use-module ((srfi srfi-1) #:hide (zip))
#:use-module (guix build-system gnu)
@@ -116,12 +115,13 @@
(define computed-origin-method (@@ (guix packages) computed-origin-method))
-(define librewolf-source
- (let* ((ff-src (firefox-source-origin "130.0"
- "0w4z3fq5zhm63a0wmhvmqrj263bvy962dir25q3z0x5hx6hjawh2"))
+(define* (make-librewolf-source #:key version firefox-hash librewolf-hash)
+ (let* ((ff-src (firefox-source-origin
+ (car (string-split version #\-))
+ firefox-hash))
(lw-src (librewolf-source-origin
- "130.0.1-1"
- "0f80pihn375bdjhjmmg2v1w96wpn76zb60ycy39wafwh1dnzybrd")))
+ version
+ librewolf-hash)))
(origin
(method computed-origin-method)
@@ -220,7 +220,10 @@
(version "130.0.1-1")
(source
(origin
- (inherit librewolf-source)
+ (inherit (make-librewolf-source
+ #:version version
+ #:firefox-hash "0w4z3fq5zhm63a0wmhvmqrj263bvy962dir25q3z0x5hx6hjawh2"
+ #:librewolf-hash "0f80pihn375bdjhjmmg2v1w96wpn76zb60ycy39wafwh1dnzybrd"))
(patches
(search-patches "librewolf-add-paths-to-rdd-allowlist.patch"))))
(build-system gnu-build-system)