aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-11 22:24:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-11-07 12:33:26 -0500
commite4443561d2b40d428548bc1a32032219da4f273e (patch)
tree4b847c358be657a1f1f4f7bd9c46de9828b42e44 /gnu/packages/libreoffice.scm
parent370468c5471a8bbb9862f8ec0d6b7aa3daa436cb (diff)
downloadguix-e4443561d2b40d428548bc1a32032219da4f273e.tar
guix-e4443561d2b40d428548bc1a32032219da4f273e.tar.gz
gnu: orcus: Update to 0.19.0.
* gnu/packages/libreoffice.scm (orcus): Update to 0.19.0. [source]: Use git-fetch/lfs. [arguments]: Use gexps. [native-inputs]: Add autoconf, automake and libtool. Change-Id: I76efbc57ca4acf8ffd5154a72e49b4aedd071a76
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index e38095fb1e..572077a0ee 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -117,22 +117,22 @@ their dependencies automatically upon calculation.")
(define-public orcus
(package
(name "orcus")
- (version "0.17.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://kohei.us/files/orcus/src/lib"
- "orcus-" version ".tar.xz"))
- (sha256
- (base32
- "1as04qb74jnlnwy4wh5jwaw2nnzgn2s3230ymvh3kx1w9r0rsl1h"))))
+ (version "0.19.0")
+ (source (origin
+ ;; The test suite requires data files store with Git Large
+ ;; File Storage.
+ (method git-fetch/lfs)
+ (uri (git-reference
+ (url "https://gitlab.com/orcus/orcus")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02prj6kgph56fkr89k8wlqarrmx65cq92863i4rrny5sqr8c2llr"))))
(build-system gnu-build-system)
- (arguments
- `(#:configure-flags '("--disable-static")))
- (native-inputs
- (list pkg-config))
- (inputs
- (list ixion mdds python zlib))
+ (arguments (list #:configure-flags #~(list "--disable-static")))
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (inputs (list ixion mdds python zlib))
(home-page "https://gitlab.com/orcus/orcus")
(synopsis "File import filter library for spreadsheet documents")
(description "Orcus is a library that provides a collection of standalone