aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-10-11 14:02:19 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-17 10:45:10 +0200
commitc2cb1160322c5b18b839b3c2ab0d53fb78793125 (patch)
treeff76230412da6cbce0a9f3dbe400b8f7b91a7927 /gnu/packages/libreoffice.scm
parent76de39c3401c8863613e628e16e65abb1204aa5a (diff)
downloadguix-c2cb1160322c5b18b839b3c2ab0d53fb78793125.tar
guix-c2cb1160322c5b18b839b3c2ab0d53fb78793125.tar.gz
gnu: Add hunspell-dict-hu.
* gnu/packages/libreoffice.scm (hunspell-dict-hu): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index b4b51a9d50..8343f8ffc6 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -73,6 +73,7 @@
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages logging)
+ #:use-module (gnu packages m4)
#:use-module (gnu packages maths)
#:use-module (gnu packages nss)
#:use-module (gnu packages openldap)
@@ -83,6 +84,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages rdf)
#:use-module (gnu packages scanner)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xml)
@@ -996,6 +998,53 @@ patterns, which are pre-processed by a perl script.")
(license
(list license:mpl1.1 license:mpl2.0 license:gpl2+ license:lgpl2.1+))))
+(define-public hunspell-dict-hu
+ (let ((revision "2")
+ (major+minor "1.7"))
+ (package
+ (name "hunspell-dict-hu")
+ (version (string-append major+minor "-" revision))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/magyarispell/Magyar Ispell/"
+ major+minor
+ "/magyarispell-" version ".tar.gz"))
+ (sha256
+ (base32 "0r22rvqrp5bzgr9sqyap82kibi5z9n6xy5b06si28idqijw7c772"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list "myspell"
+ "--jobs=1" ;the Makefile is not ready for parallelism
+ (string-append "SH="
+ (search-input-file %build-inputs
+ "/bin/bash"))
+ (string-append "AWK="
+ (search-input-file %build-inputs
+ "/bin/awk")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "config"
+ (("/usr/bin/awk")
+ (which "awk")))))
+ (replace 'install ;no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share/hunspell/")))
+ (install-file "hu_HU.aff" share)
+ (install-file "hu_HU.dic" share)))))
+ #:tests? #f)) ; no tests
+ (native-inputs
+ (list hunspell m4 recode))
+ (synopsis "Hunspell dictionary for Hungarian (hu_HU)")
+ (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+ (home-page "http://magyarispell.sourceforge.net/")
+ (license (list license:gpl2 license:gpl3)))))
+
(define-public mythes
(package
(name "mythes")