aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libphidget.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-02 10:59:27 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-02 10:59:27 +0200
commitadb5f46940aec2a58446c647487998beaa31f412 (patch)
treeaf06a1d88c8b20583716339d41f84f0280095ff0 /gnu/packages/libphidget.scm
parent2c6ab6ccd430550dfbc95fbdd22ae017f39e5901 (diff)
downloadguix-adb5f46940aec2a58446c647487998beaa31f412.tar
guix-adb5f46940aec2a58446c647487998beaa31f412.tar.gz
gnu: Add libphidget.
* gnu/packages/libphidget.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu/packages/libphidget.scm')
-rw-r--r--gnu/packages/libphidget.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/libphidget.scm b/gnu/packages/libphidget.scm
new file mode 100644
index 0000000000..0f4ae5f965
--- /dev/null
+++ b/gnu/packages/libphidget.scm
@@ -0,0 +1,42 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libphidget)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages libusb))
+
+(define-public libphidget
+ (package
+ (name "libphidget")
+ (version "2.1.8.20130320")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.phidgets.com/downloads/libraries/libphidget_"
+ version ".tar.gz"))
+ (sha256
+ (base32 "09ibrz1df5ajqcm9vmx6zw8qama2rzf0961yhmmfsy629qfhyrk0"))))
+ (build-system gnu-build-system)
+ (inputs `(("libusb" ,libusb)))
+ (home-page "http://www.phidgets.com/")
+ (license lgpl3+)
+ (synopsis "C library to manipulate Phidgets")
+ (description synopsis)))