aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-22 16:12:46 +0200
committerMarius Bakke <marius@gnu.org>2022-07-23 19:43:11 +0200
commitcafb72db5d2ff5240c67e2a2684f4603977c7214 (patch)
tree275c6d485b5b9d756bc4043d720b8d3c7ff77ca6 /gnu/packages/libffi.scm
parent17f0e8d24f56bb0bdfcbc14b482cfcba30f57ad0 (diff)
downloadguix-cafb72db5d2ff5240c67e2a2684f4603977c7214.tar
guix-cafb72db5d2ff5240c67e2a2684f4603977c7214.tar.gz
gnu: python-cffi: Disable tests that fail with newer glibc.
* gnu/packages/libffi.scm (python-cffi)[arguments]: Ignore two tests.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 953f386770..0c59509a91 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -110,7 +110,12 @@ conversions for values passed between the two languages.")
"linker_so='gcc -shared')")))
(substitute* "testing/cffi0/test_ownlib.py"
(("\"cc testownlib") "\"gcc testownlib"))
- (invoke "py.test" "-v" "c/" "testing/")))
+ (invoke "pytest" "-v" "c/" "testing/"
+ ;; Disable tests that fail (harmlessly) with glibc
+ ;; 2.34 and later:
+ ;; https://foss.heptapod.net/pypy/cffi/-/issues/528
+ "-k" (string-append "not TestFFI.test_dlopen_handle "
+ "and not test_dlopen_handle"))))
(add-before 'check 'patch-paths-of-dynamically-loaded-libraries
(lambda* (#:key inputs #:allow-other-keys)
;; Shared libraries should be referred by their absolute path as