aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-14 03:00:58 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 18:32:12 +0200
commit97e298331022a21934b4b619aa813e9a34ee118d (patch)
tree16992284f9ee6a36d0652f0ec2391cb1ddc3be76 /gnu/packages/libffi.scm
parent32b7e12e77d58ed67c1a3c3123f01e487b660dbd (diff)
downloadguix-97e298331022a21934b4b619aa813e9a34ee118d.tar
guix-97e298331022a21934b4b619aa813e9a34ee118d.tar.gz
gnu: python-cffi: Remove input labels.
* gnu/packages/libffi.scm (python-cffi)[arguments]: Use SEARCH-INPUT-FILE instead of labels.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index c37baaf056..f09a43db37 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -118,9 +118,8 @@ conversions for values passed between the two languages.")
;; using find_library or the like with their name fail when the
;; resolved .so object is a linker script rather than an ELF
;; binary (this is a limitation of the ctype library of Python).
- (let* ((glibc (assoc-ref inputs "libc"))
- (libm (string-append glibc "/lib/libm.so.6"))
- (libc (string-append glibc "/lib/libc.so.6")))
+ (let ((libm (search-input-file inputs "lib/libm.so.6"))
+ (libc (search-input-file inputs "lib/libc.so.6")))
(substitute* '("testing/cffi0/test_function.py"
"testing/cffi0/test_parsing.py"
"testing/cffi0/test_unicode_literals.py"