aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-30 20:18:55 +0200
committerMarius Bakke <marius@gnu.org>2022-08-30 20:18:55 +0200
commit59c136ef611b7a00683af1d1bb406dbd1af1a2bd (patch)
tree1ab434580130c7fd11b8ef5c22a91087b8401559 /gnu/packages/libffi.scm
parenta6f42953626df657041fddfc36a207b06c38f944 (diff)
parentd62fc2cc837b095ff1a633ae2639513ea3253596 (diff)
downloadguix-59c136ef611b7a00683af1d1bb406dbd1af1a2bd.tar
guix-59c136ef611b7a00683af1d1bb406dbd1af1a2bd.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 923019c2ca..ecdeaf45cd 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -188,28 +188,22 @@ project.")
(define-public ruby-ffi
(package
(name "ruby-ffi")
- (version "1.12.2")
+ (version "1.15.5")
(source (origin
;; Pull from git because the RubyGems release bundles LibFFI,
;; and comes with a gemspec that makes it difficult to unbundle.
(method git-fetch)
(uri (git-reference
(url "https://github.com/ffi/ffi")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1cvqsbjr2gfjgqggq9kdx90qhhzr7qkyr9wmxdsfsik6cnxnnpmd"))))
+ "1qk55s1zwpdjykwkj9l37m71i5n228i7f8bg3ply3ks9py16m7s6"))))
(build-system ruby-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'do-not-depend-on-ccache
- (lambda _
- (substitute* "spec/ffi/fixtures/GNUmakefile"
- (("^CCACHE := .*")
- ""))
- #t))
(replace 'replace-git-ls-files
(lambda _
;; Do not try to execute git, or include the (un)bundled LibFFI.
@@ -219,9 +213,10 @@ project.")
(("lfs \\+?= .*")
"lfs = []\n"))
(substitute* "Rakefile"
+ (("git .*ls-files -z")
+ "find * -type f -print0 | sort -z")
(("LIBFFI_GIT_FILES = .*")
- "LIBFFI_GIT_FILES = []\n"))
- #t))
+ "LIBFFI_GIT_FILES = []\n"))))
(replace 'build
(lambda _
;; Tests depend on the native extensions, so we build it
@@ -240,8 +235,7 @@ project.")
(setenv "MAKE" "make")
(setenv "CC" "gcc")
(invoke "rspec" "spec"))
- (format #t "test suite not run~%"))
- #t)))))
+ (format #t "test suite not run~%")))))))
(native-inputs
(list ruby-rake-compiler ruby-rspec ruby-rubygems-tasks))
(inputs