aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libedit.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-02-26 09:33:57 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-03-07 15:08:36 +0100
commitc8daf5720018c1ca232bb35606278983ece66005 (patch)
tree4f93f80e10cbe8068cbb280fc275e6072668d945 /gnu/packages/libedit.scm
parenta1920bc9f25210b243ebd20f0a3624d644d08efb (diff)
downloadguix-c8daf5720018c1ca232bb35606278983ece66005.tar
guix-c8daf5720018c1ca232bb35606278983ece66005.tar.gz
gnu: Add libedit.
* gnu/packages/libedit.scm: New file.
Diffstat (limited to 'gnu/packages/libedit.scm')
-rw-r--r--gnu/packages/libedit.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/libedit.scm b/gnu/packages/libedit.scm
new file mode 100644
index 0000000000..fcf5ab4c74
--- /dev/null
+++ b/gnu/packages/libedit.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libedit)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages ncurses))
+
+(define-public libedit
+ (package
+ (name "libedit")
+ (version "20141030-3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://thrysoee.dk/editline"
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0h2svwfcdldpbg0fy7fnkld706r2a9k9h1mm0yj7z3zvf1jy20cp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "http://thrysoee.dk/editline/")
+ (synopsis "NetBSD Editline library")
+ (description
+ "This is an autotool- and libtoolized port of the NetBSD Editline
+library (libedit). This Berkeley-style licensed command line editor library
+provides generic line editing, history, and tokenization functions, similar to
+those found in GNU Readline.")
+ (license bsd-3)))
+
+;;; libedit.scm ends here