aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-02 19:13:44 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-02 19:13:44 +0100
commit5c2033f86469ed052fd89a2a228f8cb17128ddf2 (patch)
treea8fba3b99d171ac5693b9ac6e95a8969bc386e69 /gnu/packages/kde.scm
parent833fdac028127caed52b3447f6a0dc229f13e861 (diff)
downloadguix-5c2033f86469ed052fd89a2a228f8cb17128ddf2.tar
guix-5c2033f86469ed052fd89a2a228f8cb17128ddf2.tar.gz
gnu: Add oxygen-icons.
* gnu/packages/kde.scm (oxygen-icons): New variable.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 3500b0a972..8c2673e20d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -17,7 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages kde)
- #:use-module ((guix licenses) #:select (bsd-2 lgpl2.0+ lgpl2.1 lgpl2.1+))
+ #:use-module ((guix licenses) #:select (bsd-2 lgpl2.0+ lgpl2.1 lgpl2.1+ lgpl3+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
@@ -205,3 +205,23 @@ simple interface for implementing plugins for extracting information;
calculation of sha1 for every file crawled
(allows fast finding of duplicates).")
(license lgpl2.0+)))
+
+(define-public oxygen-icons
+ (package
+ (name "oxygen-icons")
+ (version "4.14.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.kde.org/stable/" version
+ "/src/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1mz73f54qh2vd8ibp60f6fjflrprz0lvqfkgh805l7wfhrv4ckbz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test target
+ (home-page "http://www.kde.org/")
+ (synopsis "oxygen icon theme for the KDE desktop")
+ (description "KDE desktop environment")
+ (license lgpl3+)))