aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-01 18:02:55 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-03 17:38:10 +0800
commitf0ee89c377c226a9f5c917477b3523f8775822bd (patch)
tree61c35946580774dbf02fc9f91958cfec72bed123 /gnu/packages/kde-plasma.scm
parentc9fd3d1b84086b3f0e95e2473fb40248d202bc53 (diff)
downloadguix-f0ee89c377c226a9f5c917477b3523f8775822bd.tar
guix-f0ee89c377c226a9f5c917477b3523f8775822bd.tar.gz
gnu: Add kpipewire.
* gnu/packages/kde-plasma.scm (kpipewire): New variable.
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 4927e30705..b4579c9e0d 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -692,6 +692,35 @@ computer's hardware.")
the schedule and venue information.")
(license license:gpl3+)))
+(define-public kpipewire
+ (package
+ (name "kpipewire")
+ (version "5.27.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12rjwkk272r9r583vgxb64p5nylkcqsfyvbn0lpa6ap8q2zm7mky"))))
+ (build-system cmake-build-system)
+ (native-inputs (list extra-cmake-modules pkg-config))
+ (propagated-inputs (list libepoxy pipewire qtbase-5 qtdeclarative-5))
+ (inputs (list ffmpeg
+ kcoreaddons
+ ki18n
+ kwayland
+ plasma-wayland-protocols
+ qtwayland-5
+ wayland
+ wayland-protocols))
+ (home-page "https://invent.kde.org/plasma/kpipewire")
+ (synopsis "Components relating to pipewire use in Plasma")
+ (description "This package offers a set of convenient classes to use
+PipeWire in Qt projects.")
+ ;; LGPL-2.1-only OR LGPL-3.0-only OR LicenseRef-KDE-Accepted-LGPL
+ (license (list license:lgpl2.1 license:lgpl3))))
+
(define-public kscreen
(package
(name "kscreen")