aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-24 17:16:11 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:14 +0100
commit9946e5800f4de17e1186cdc405f0ce4acf74afaf (patch)
treeef53c950b33895c77f31e50da9a0db5ff55e0b94 /gnu/packages/kde-plasma.scm
parent576d8c5babcd52222f7b5dfe7054e2188f23d4bd (diff)
downloadguix-9946e5800f4de17e1186cdc405f0ce4acf74afaf.tar
guix-9946e5800f4de17e1186cdc405f0ce4acf74afaf.tar.gz
gnu: Add lightly.
* gnu/packages/kde-plasma.scm (lightly): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 6929232290..b0d2d36ed9 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1292,6 +1292,36 @@ conjunction with the KDE Plasma Desktop.")
"This package provides a daemon that listens to system notifications.")
(license license:gpl2+)))
+(define-public lightly
+ (package
+ (name "lightly")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Luwx/Lightly")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qkjzgjplgwczhk6959iah4ilvazpprv7yb809jy75kkp1jw8mwk"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list kdecoration
+ kcoreaddons
+ kguiaddons
+ kconfigwidgets
+ kwindowsystem
+ ki18n
+ kiconthemes
+ qtx11extras))
+ (home-page "https://github.com/Luwx/Lightly")
+ (synopsis "Modern style for Qt applications")
+ (description
+ "Lightly is a fork of the Breeze theme that aims to be visually modern
+and minimalistic.")
+ (license license:gpl2+)))
+
(define-public milou
(package
(name "milou")