aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-07 22:18:59 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:22 +0800
commit21b760d030b85e850f6e017c36e565b01ab3bc85 (patch)
treef387b4fbf02caea2f996018534e92cc446689c9a /gnu/packages/kde-pim.scm
parentce62f72078446d8e1c74a738b9bb784f83053d7f (diff)
downloadguix-21b760d030b85e850f6e017c36e565b01ab3bc85.tar
guix-21b760d030b85e850f6e017c36e565b01ab3bc85.tar.gz
gnu: libkleo: Update to 24.05.2.
* gnu/packages/kde-pim.scm (libkleo): Update to 24.05.2. [inputs]: Remove gpgme, qgpgme, and qtbase-5; add gpgme-1.23 and qgpgme-qt6-1.23. [propagated-inputs]: Remove gpgme and qgpgme; add gpgme-1.23 and qgpgme-qt6-1.23; Remove label. [native-inputs]: Remove qttools-5; add qttools. [arguments]: Set #:qtbase to qtbase; Use Gexps. <#:phases>: Disable expirycheckertest test. Change-Id: I4ada25120ce9297bb4ab04d9b4a5e224d03f4c2d
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 375a2ccd17..3855c44acd 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -2173,20 +2173,20 @@ various Google services.")
(define-public libkleo
(package
(name "libkleo")
- (version "23.04.3")
+ (version "24.05.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/libkleo-" version ".tar.xz"))
(sha256
- (base32 "0l77n4dlbv9hclzvh69kdzji907if7yayxiasxnnjkzsvcm1af25"))))
+ (base32 "102yszx6smyf2vd068p6j0921fql5jlmsra3n62xam81smqlpgj0"))))
(build-system qt-build-system)
(native-inputs
- (list extra-cmake-modules kdoctools qttools-5))
+ (list extra-cmake-modules kdoctools qttools))
(inputs
(list boost
- gpgme
+ gpgme-1.23
kcodecs
kcompletion
kconfig
@@ -2198,19 +2198,20 @@ various Google services.")
kwidgetsaddons
kwindowsystem
kpimtextedit
- qgpgme
- qtbase-5))
+ qgpgme-qt6-1.23))
(propagated-inputs
- `(("gpgme" ,gpgme)
- ("qgpgme" ,qgpgme)))
+ (list gpgme-1.23 qgpgme-qt6-1.23))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? ;; FIXME: These tests fail.
- (invoke "ctest" "-E"
- "(keyresolvercoretest|newkeyapprovaldialogtest)")))))))
+ (list
+ #:qtbase qtbase
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? ;; FIXME: These tests fail.
+ (invoke "ctest" "-E"
+ "(expirycheckertest|keyresolvercoretest|\
+newkeyapprovaldialogtest)")))))))
(home-page "https://invent.kde.org/pim/libkleo")
(synopsis "KDE PIM cryptographic library")
(description "@code{libkleo} is a library for Kleopatra and other parts of