aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-office.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-10-27 21:38:15 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-28 12:29:38 +0800
commit67c755e6b37067209cabfaa407c9aba2bf59b369 (patch)
tree1dbb0194b792bb6a865cbd1bd282f2438e0f8620 /gnu/packages/kde-office.scm
parentbc00808ca81573ee0e1b8163c9d42617519923f5 (diff)
downloadguix-67c755e6b37067209cabfaa407c9aba2bf59b369.tar
guix-67c755e6b37067209cabfaa407c9aba2bf59b369.tar.gz
gnu: Add ghostwriter.
* gnu/packages/kde-office.scm (ghostwriter): New variable. Change-Id: I634e4ecab8c53aa67eb521f479d1acff6540c9fe Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/kde-office.scm')
-rw-r--r--gnu/packages/kde-office.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/kde-office.scm b/gnu/packages/kde-office.scm
index c4e3c757b5..96c8318225 100644
--- a/gnu/packages/kde-office.scm
+++ b/gnu/packages/kde-office.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages graphics)
+ #:use-module (gnu packages hunspell)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages libreoffice)
@@ -142,3 +143,42 @@ Advanced plugins:
@item KFormula: Mathematical formulas
@end itemize")
(license (list license:lgpl2.0+ license:gpl2+))))
+
+(define-public ghostwriter
+ (package
+ (name "ghostwriter")
+ (version "24.05.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/ghostwriter-" version ".tar.xz"))
+ (sha256
+ (base32 "181izld9wnbwlknw7h876ysranqqvbvb0h2p4ky54jfb82f9h513"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase
+ #:configure-flags
+ #~(list "-DQT_MAJOR_VERSION=6"
+ "-DBUILD_TESTING=ON")))
+ (native-inputs
+ (list extra-cmake-modules kdoctools pkg-config qttools))
+ (inputs
+ (list hunspell
+ kconfigwidgets
+ kcoreaddons
+ kwidgetsaddons
+ kxmlgui
+ qt5compat
+ qtsvg
+ qtwebchannel
+ qtwebengine
+ sonnet))
+ (home-page "https://ghostwriter.kde.org/")
+ (synopsis "Text editor for Markdown")
+ (description "@code{ghostwriter} is a text editor for Markdown, which is a plain
+text markup format. It features a live HTML preview as you type, theme
+creation, focus mode, fullscreen mode, live word count, and document navigation
+in an aesthetic writing environment. It comes with the cmark-gfm Markdown
+processor built in, and can integrate with Pandoc, MultiMarkdown, Discount, and
+cmark processors if they are installed.")
+ (license license:gpl3+)))