aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-games.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-05 15:37:57 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-05 15:37:57 +0800
commit1e4085670a149df7e9858ef6c52995415cf27037 (patch)
treefc29abc7277c14f803f943c33e221c929e0d38d8 /gnu/packages/kde-games.scm
parent0a4490e4fd77a0dd50262d080bd024a2f41cdc4a (diff)
downloadguix-1e4085670a149df7e9858ef6c52995415cf27037.tar
guix-1e4085670a149df7e9858ef6c52995415cf27037.tar.gz
gnu: kajongg: Hardcode paths to 'ogg123' and 'python3'.
* gnu/packages/kde-games.scm (kajongg)[inputs]: Add vorbis-tools. [arguments]<#:phases>: Hardcode paths to 'ogg123' and 'python3'.
Diffstat (limited to 'gnu/packages/kde-games.scm')
-rw-r--r--gnu/packages/kde-games.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/kde-games.scm b/gnu/packages/kde-games.scm
index a47deb6c68..9e2b885c2b 100644
--- a/gnu/packages/kde-games.scm
+++ b/gnu/packages/kde-games.scm
@@ -37,7 +37,8 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
- #:use-module (gnu packages qt))
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages xiph))
(define-public ktuberling
(package
@@ -300,7 +301,15 @@ This package is part of the KDE games module.")
(substitute* "src/mjresource.py"
(("'share', 'kmahjongglib'" all)
(string-append "'" (assoc-ref inputs "libkmahjongg")
- "/share', 'kmahjongglib'")))))
+ "/share', 'kmahjongglib'")))
+ (substitute* "src/sound.py"
+ (("oggBinary = 'ogg123'")
+ (format #f "oggBinary = '~a'"
+ (search-input-file inputs "bin/ogg123"))))
+ (substitute* "src/common.py"
+ (("interpreterName = 'python3'")
+ (format #f "interpreterName = '~a'"
+ (search-input-file inputs "bin/python3"))))))
(add-after 'qt-wrap 'wrap
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -327,7 +336,8 @@ This package is part of the KDE games module.")
python-qtpy
python-zope-interface
qtbase-5
- qtsvg-5))
+ qtsvg-5
+ vorbis-tools))
(home-page "https://apps.kde.org/kajongg/")
(synopsis "Classical Mah Jongg game for 4 players")
(description "Kajongg is the ancient Chinese board game for 4 players.