aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 01:15:24 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:03 +0800
commite1fa2e2f4e489bb4e11ae6b7290441ae390319ea (patch)
tree28683138cf37480d4518de63a9026d510ce8bf5b /gnu/packages/kde-frameworks.scm
parent44f2739faa6bab5428f9814eb021422098e624cd (diff)
downloadguix-e1fa2e2f4e489bb4e11ae6b7290441ae390319ea.tar
guix-e1fa2e2f4e489bb4e11ae6b7290441ae390319ea.tar.gz
gnu: kconfigwidgets: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kconfigwidgets): Update to 6.3.0. [inputs]: Remove qtbase-5 and qttools-5; add qtdeclarative and libxkbcommon. [propagated-inputs]: Remove kauth; add kcolorscheme. [native-inputs]: Remove qttools-5; add qttools. [arguments]: Set #:qtbase to qtbase; Adjust patch phase. Change-Id: Ie6777af00cad1cebe351ce1017d4b7e8a4a83bff
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 4d4436091b..beaca6bf07 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2343,7 +2343,7 @@ KCModules can be created with the KConfigWidgets framework.")
(define-public kconfigwidgets
(package
(name "kconfigwidgets")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2352,21 +2352,22 @@ KCModules can be created with the KConfigWidgets framework.")
name "-" version ".tar.xz"))
(sha256
(base32
- "16layydkcwfbvzxqjzprkq8bbxifn0z0wm7mc9bzwrfxy761rjnj"))))
+ "14104r6j38kjqmvx3d66xm4amdbdxl1450257l6zlf9wp1lndj5s"))))
(build-system qt-build-system)
(propagated-inputs
- (list kauth kcodecs kconfig kwidgetsaddons))
+ (list kcodecs kconfig kcolorscheme kwidgetsaddons))
(native-inputs
- (list extra-cmake-modules kdoctools qttools-5))
+ (list extra-cmake-modules kdoctools qttools))
(inputs
(list kcoreaddons
kguiaddons
ki18n
;; todo: PythonModuleGeneration
- qtbase-5
- qttools-5))
+ qtdeclarative
+ libxkbcommon))
(arguments
(list
+ #:qtbase qtbase
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch
@@ -2380,7 +2381,8 @@ KCModules can be created with the KConfigWidgets framework.")
(when tests?
(setenv "HOME"
(getcwd))
- (invoke "ctest" "-E" "kstandardactiontest")))))))
+ (invoke "ctest" "-E" "(kstandardactiontest|\
+klanguagenametest)")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Widgets for configuration dialogs")
(description "KConfigWidgets provides easy-to-use classes to create