aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 00:53:36 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:02 +0800
commitc12d0e371f50bafa05fcd31f5e4d6940ca5e0dbd (patch)
tree70ca73c1082fa80434be5bafd63f0004c8a989c0 /gnu/packages/kde-frameworks.scm
parenta3a8c9dc7186daa4c166df196eaa41fe4881e124 (diff)
downloadguix-c12d0e371f50bafa05fcd31f5e4d6940ca5e0dbd.tar
guix-c12d0e371f50bafa05fcd31f5e4d6940ca5e0dbd.tar.gz
gnu: knotifications: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (knotifications): Update to 6.3.0. [inputs]: Remove kcodecs, kwindowsystem, libdbusmenu-qt, phonon, qtdeclarative-5, qtbase-5, qtspeech-5, and qtx11extras; add qtbase. [propagated-inputs]: Add qtdeclarative. [native-inputs]: Remove dbus and qttools-5; add qttools. [arguments]: Stop replace check phase. Change-Id: I2daeff7752ef88d94cb2df0ddc2c6c65cfb09ec9
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 6 insertions, 21 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index bbe14cd2eb..6cfb5ab47f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1947,7 +1947,7 @@ asynchronous jobs.")
(define-public knotifications
(package
(name "knotifications")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1956,31 +1956,16 @@ asynchronous jobs.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0cjd5ml9hyzprjgmrc132cmp7g9hnl0h5swlxw2ifqnxxyfkg72b"))))
+ "0xvqri0ykx9qb6q2gjpxri71jvghzwy6p332vj8drzlm6wd3rvfc"))))
(build-system cmake-build-system)
(native-inputs
- (list extra-cmake-modules dbus pkg-config qttools-5))
+ (list extra-cmake-modules pkg-config qttools))
+ (propagated-inputs (list qtdeclarative))
(inputs
- (list kcodecs
- kconfig
+ (list kconfig
kcoreaddons
- kwindowsystem
libcanberra
- libdbusmenu-qt
- phonon
- qtdeclarative-5
- qtbase-5
- qtspeech-5
- qtx11extras))
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "HOME"
- (getcwd))
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "ctest")))))))
+ qtbase))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Desktop notifications")
(description "KNotification is used to notify the user of an event. It