aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 10:29:13 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:05 +0800
commit1c26ad5cf6c5ca58bfa85f89939d7dfeb6988845 (patch)
tree992b47741d68e48d42b8656b395dae03f99c789f /gnu/packages/kde-frameworks.scm
parentcf80b602815dd7f4cfa01025706401fb8fddd95d (diff)
downloadguix-1c26ad5cf6c5ca58bfa85f89939d7dfeb6988845.tar
guix-1c26ad5cf6c5ca58bfa85f89939d7dfeb6988845.tar.gz
gnu: kwayland: Update to 6.1.2.
* gnu/packages/kde-frameworks.scm (kwayland): Update to 6.1.2. [inputs]: Remove qtbase-5 and qtwayland-5; add qtwayland. [native-inputs]: Add wayland. [source]: Update url. [arguments]: Remove phases; Set #:qtbase to qtbase. [home-page]: Update url. Change-Id: Ia9229605caebac84092bf45150cd40a13c359ccc
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm44
1 files changed, 11 insertions, 33 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 1eeb256f72..c766e2d3aa 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1181,51 +1181,29 @@ protocols used in KDE Plasma.")
(define-public kwayland
(package
(name "kwayland")
- (version "5.114.0")
+ (version "6.1.2")
(source (origin
(method url-fetch)
- (uri (string-append
- "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version "/kwayland" "-"
+ version ".tar.xz"))
(sha256
(base32
- "1lzmlbv5vl656cigjj07hbc0gj6g1i2xqanvnhxj360109kzilf1"))))
+ "15dmbcqhajqc100k95y6nh0w2br8xwql4mlq8grh4r6cdgn378n6"))))
(build-system qt-build-system)
(native-inputs
- (list extra-cmake-modules pkg-config))
+ (list extra-cmake-modules pkg-config
+ ;; for wayland-scanner
+ wayland))
(inputs
(list libxkbcommon
plasma-wayland-protocols
- qtbase-5
- qtwayland-5
+ qtwayland
wayland
wayland-protocols))
(arguments
- (list
- ;; Tests spawn Wayland sessions that cannot run in parallel.
- #:parallel-tests? #f
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'check 'set-XDG_RUNTIME_DIR
- (lambda _
- (setenv "XDG_RUNTIME_DIR" (getcwd))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "ctest" "-E"
- (string-append
- "("
- (string-join
- ;; XXX: maybe is upstream bug
- '("kwayland-testWaylandRegistry"
- "kwayland-testPlasmaShell"
- "kwayland-testPlasmaWindowModel"
- ;; The 'kwayland-testXdgForeign' may fail on
- ;; powerpc64le with a 'Subprocess aborted' error.
- "kwayland-testXdgForeign") "|")
- ")"))))))))
- (home-page "https://community.kde.org/Frameworks")
+ (list #:qtbase qtbase))
+ (home-page "https://invent.kde.org/plasma/kwayland")
(synopsis "Qt-style API to interact with the wayland client and server")
(description "As the names suggest they implement a Client respectively a
Server API for the Wayland protocol. The API is Qt-styled removing the needs to