aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 11:42:26 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:24 +0800
commit1099c670ab93e66e663c1727f2e79103f4b253dc (patch)
tree941fd88b2cbc0824e26fc535b13d09ad103a46ef /gnu/packages/kde-frameworks.scm
parente2c0a0bdd7e24a07524e9c4d830ff307ecc98abf (diff)
downloadguix-1099c670ab93e66e663c1727f2e79103f4b253dc.tar
guix-1099c670ab93e66e663c1727f2e79103f4b253dc.tar.gz
gnu: kapidox: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kapidox): Update to 6.3.0. [inputs]: Remove qtbase-5; add qtbase. [propagated-inputs]: Add python-requests. Change-Id: If0e40de101af3b66e8e1a2d4dd0bf4b9ae7d73bc
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index c4e6146c3f..43e47e0a9a 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -87,6 +87,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages qt)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -419,7 +420,7 @@ It is the default icon theme for the KDE Plasma desktop.")
(define-public kapidox
(package
(name "kapidox")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -428,7 +429,7 @@ It is the default icon theme for the KDE Plasma desktop.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0xxw3lvipyax8r1af3ypwjj6waarbp2z9n11fjb4kvyigsypglmb"))))
+ "0knp680462dr9ib2b4dgz18659i1a33d6gmvnqh3k4mm659rrlr1"))))
(build-system python-build-system)
(arguments
(list #:tests? #f ; test need network
@@ -439,9 +440,9 @@ It is the default icon theme for the KDE Plasma desktop.")
;; TODO: check if doxygen has to be installed, the readme does not
;; mention it. The openSuse .rpm lists doxygen, graphviz, graphviz-gd,
;; and python-xml.
- (list python python-jinja2 python-pyyaml))
+ (list python python-jinja2 python-pyyaml python-requests))
(inputs
- (list qtbase-5))
+ (list qtbase))
(home-page "https://community.kde.org/Frameworks")
(synopsis "KDE Doxygen Tools")
(description "This framework contains scripts and data for building API