aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 00:59:55 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:15 +0100
commitc157ed08c73875f1235451775b5167ae5fc57ae1 (patch)
treec6ca1e16e5e26160879d162835b56acf2963150f /gnu/packages/jupyter.scm
parentfb6de84a6b9ed38fc4fbf4fad89a0f8fe25111eb (diff)
downloadguix-c157ed08c73875f1235451775b5167ae5fc57ae1.tar
guix-c157ed08c73875f1235451775b5167ae5fc57ae1.tar.gz
gnu: repo2docker: Update to 2021.08.0.
* gnu/packages/jupyter.scm (repo2docker): Update to 2021.08.0. [arguments]: Disable Sphinx warnings, set PYTHONPATH, and refer to THIS-PACKAGE instead of the "name" variable directly. [native-inputs]: Add PYTHON-ENTRYPOINTS.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 56ced35204..dd5d2a5a55 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -370,16 +371,16 @@ nbconvert's @code{ExecutePreprocessor.}")
(define-public repo2docker
(package
(name "repo2docker")
- (version "2021.03.0")
+ (version "2021.08.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/jupyterhub/repo2docker/")
- (commit "2021.03.0")))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "18w8rgf7fpf79kx36y2c3xi3d52i41z112l3sz719d8kg0bir16m"))))
+ "111irpghzys0s5ixs8paskz7465cls1sm9d5bg45a15jklcw84a9"))))
(outputs '("out" "doc"))
(build-system python-build-system)
(arguments
@@ -399,10 +400,14 @@ nix-shell-wrapper|repo2docker-entrypoint)")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "doc"))
(doc (string-append out "/share/doc/"
- ,name)))
- (setenv "GUIX_PYTHONPATH"
+ ,(package-name this-package))))
+ (setenv "PYTHONPATH"
(string-append (getcwd) ":"
(getenv "GUIX_PYTHONPATH")))
+ ;; Don't treat warnings as errors.
+ (substitute* "docs/Makefile"
+ (("(SPHINXOPTS[[:blank:]]+= )-W" _ group)
+ group))
(with-directory-excursion "docs"
(invoke "make" "html")
(copy-recursively "build/html"
@@ -418,7 +423,7 @@ nix-shell-wrapper|repo2docker-entrypoint)")
python-escapism
python-docker))
(native-inputs
- (list python-sphinx python-recommonmark
+ (list python-sphinx python-entrypoints python-recommonmark
python-sphinxcontrib-autoprogram python-pydata-sphinx-theme))
(home-page "https://repo2docker.readthedocs.io/en/latest/index.html#")
(synopsis "Generate docker images from repositories")